{"answers":{"affected":"2 open source packages ship an affected version, including winter/wn-backend-module.","exploited":"There is no known exploitation of GHSA-5cwr-5jxg-pcf6 in the wild and no public exploit code.","fix":"Upgrade winter/wn-backend-module to 1.2.14 or later.","what":"GHSA-5cwr-5jxg-pcf6 is a cross-site scripting vulnerability in winter/wn-backend-module, published on 20 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-5cwr-5jxg-pcf6 and fix it if it is affected.\n\nWhat it is: GHSA-5cwr-5jxg-pcf6 is a cross-site scripting vulnerability in winter/wn-backend-module, published on 20 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-5cwr-5jxg-pcf6 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- winter/wn-backend-module (Packagist): affected all versions; fixed in 1.2.14\n- winter/wn-backend-module (Packagist): affected all versions; fixed in 1.2.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-5cwr-5jxg-pcf6/ (Markdown: https://insights.sbomify.com/GHSA-5cwr-5jxg-pcf6/index.md)","id":"GHSA-5cwr-5jxg-pcf6","markdown":"https://insights.sbomify.com/GHSA-5cwr-5jxg-pcf6/index.md","name":"GHSA-5cwr-5jxg-pcf6","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Winter CMS","requires_auth":"high_privilege","summary":"Privileged users can inject stored XSS via cached CSS settings, affecting authenticated and unauthenticated backend pages.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nUsers with the `backend.manage_branding` (\"Customize the back-end\") or `backend.manage_editor` (\"Manage global code editor preferences\") permission can provide custom CSS through **Settings → Customize Backend → Styles** or **Settings → Editor Settings → Markup Styles** that is compiled through the LESS CSS parser and rendered on every backend page.\n\nv1.2.13 addressed CVE-2026-32257 and CVE-2026-32258 by applying `strip_tags()` to the compiled output of `BrandSetting::renderCss()` and `EditorSetting::renderCss()`. That fix was incomplete. Both methods cache the **raw** compiler output with `Cache::forever()` and applied `strip_tags()` only to the value returned on a cache miss, so every subsequent cache hit returned the unsanitized value directly into the backend `\u003cstyle\u003e` element. The first page render after saving therefore appears sanitized while priming an unsafe cache entry, and the stored XSS remains exploitable from the second render onwards.\n\nBecause the custom styles partial is included by both the standard backend layout head and the backend authentication layout, an injected payload also renders on the unauthenticated backend sign-in, password restore, and password reset pages.\n\nAlthough this is a valid security issue, it's important to note that its severity is relatively low. To exploit the vulnerability, an attacker would already need to have trusted access to the Winter CMS backend with a specific administrative permission. The Winter CMS maintainers recommend that the `backend.manage_branding` and `backend.manage_editor` permissions only be granted to trusted administrators and developers.\n\nAll users are advised to update to the latest version to ensure their systems remain secure.\n\n### Patches\n\nThis issue has been patched in v1.2.14. The `renderCss()` methods now apply `strip_tags()` to the cached value when it is read back, which also neutralizes any cache entry that was poisoned before upgrading.\n\nThe `backend.manage_editor` and `backend.manage_default_dashboard` permissions have additionally been given warning comments in the permission editor, matching the existing warning on `backend.manage_branding`.\n\n### Workarounds\n\nApply [https://github.com/wintercms/winter/commit/c95d780ab54f3a3f74a94ae1667bf12b3c549d5d](https://github.com/wintercms/winter/commit/c95d780ab54f3a3f74a94ae1667bf12b3c549d5d) manually if unable to upgrade to v1.2.14.\n\nClearing the application cache removes an already-poisoned entry, but it will be recreated on the next backend page render unless the patch is applied.\n\n### References\n\n- CVE-2026-32257 / GHSA-v7cf-8gh9-gxmj (Stored XSS through Brand Settings custom styles, incompletely patched in v1.2.13)\n- CVE-2026-32258 / GHSA-vgp4-2fc4-qff2 (Stored XSS through Editor Settings custom styles, incompletely patched in v1.2.13)\n- CVE-2025-61674 and CVE-2025-61676 (identical vulnerability in October CMS, patched in v3.7.13 and v4.0.12)","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Winter: Stored XSS through cached Brand Settings and Editor Settings custom styles","id":"GHSA-5cwr-5jxg-pcf6","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.2.14"],"introduced":["0"],"last_affected":[],"package":"winter/wn-backend-module","purl":null,"source":"GHSA-5cwr-5jxg-pcf6"},{"ecosystem":"Packagist","fixed":["1.2.14"],"introduced":["0"],"last_affected":[],"package":"winter/wn-backend-module","purl":"pkg:composer/winter/wn-backend-module","source":"GHSA-5cwr-5jxg-pcf6"}],"products":null,"published":"2026-08-20","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Privileged users can inject stored XSS via cached CSS settings, affecting authenticated and unauthenticated backend pages.","url":"https://insights.sbomify.com/GHSA-5cwr-5jxg-pcf6/"}