# GHSA-5cwr-5jxg-pcf6: Winter: Stored XSS through cached Brand Settings and Editor Settings custom styles

> Privileged users can inject stored XSS via cached CSS settings, affecting authenticated and unauthenticated backend pages.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2026

## What is GHSA-5cwr-5jxg-pcf6?

GHSA-5cwr-5jxg-pcf6 is a cross-site scripting vulnerability in winter/wn-backend-module, published on 20 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

### Impact

Users with the `backend.manage_branding` ("Customize the back-end") or `backend.manage_editor` ("Manage global code editor preferences") permission can provide custom CSS through **Settings → Customize Backend → Styles** or **Settings → Editor Settings → Markup Styles** that is compiled through the LESS CSS parser and rendered on every backend page.

v1.2.13 addressed CVE-2026-32257 and CVE-2026-32258 by applying `strip_tags()` to the compiled output of `BrandSetting::renderCss()` and `EditorSetting::renderCss()`. That fix was incomplete. Both methods cache the **raw** compiler output with `Cache::forever()` and applied `strip_tags()` only to the value returned on a cache miss, so every subsequent cache hit returned the unsanitized value directly into the backend `<style>` element. The first page render after saving therefore appears sanitized while priming an unsafe cache entry, and the stored XSS remains exploitable from the second render onwards.

Because the custom styles partial is included by both the standard backend layout head and the backend authentication layout, an injected payload also renders on the unauthenticated backend sign-in, password restore, and password reset pages.

Although this is a valid security issue, it's important to note that its severity is relatively low. To exploit the vulnerability, an attacker would already need to have trusted access to the Winter CMS backend with a specific administrative permission. The Winter CMS maintainers recommend that the `backend.manage_branding` and `backend.manage_editor` permissions only be granted to trusted administrators and developers.

All users are advised to update to the latest version to ensure their systems remain secure.

### Patches

This issue has been patched in v1.2.14. The `renderCss()` methods now apply `strip_tags()` to the cached value when it is read back, which also neutralizes any cache entry that was poisoned before upgrading.

The `backend.manage_editor` and `backend.manage_default_dashboard` permissions have additionally been given warning comments in the permission editor, matching the existing warning on `backend.manage_branding`.

### Workarounds

Apply [https://github.com/wintercms/winter/commit/c95d780ab54f3a3f74a94ae1667bf12b3c549d5d](https://github.com/wintercms/winter/commit/c95d780ab54f3a3f74a94ae1667bf12b3c549d5d) manually if unable to upgrade to v1.2.14.

Clearing the application cache removes an already-poisoned entry, but it will be recreated on the next backend page render unless the patch is applied.

### References

- CVE-2026-32257 / GHSA-v7cf-8gh9-gxmj (Stored XSS through Brand Settings custom styles, incompletely patched in v1.2.13)
- CVE-2026-32258 / GHSA-vgp4-2fc4-qff2 (Stored XSS through Editor Settings custom styles, incompletely patched in v1.2.13)
- CVE-2025-61674 and CVE-2025-61676 (identical vulnerability in October CMS, patched in v3.7.13 and v4.0.12)

## Which versions are affected by GHSA-5cwr-5jxg-pcf6?

2 open source packages ship an affected version, including winter/wn-backend-module.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `winter/wn-backend-module` | Packagist | All versions | 1.2.14 |
| `winter/wn-backend-module` | Packagist | All versions | 1.2.14 |

## How do I fix GHSA-5cwr-5jxg-pcf6?

Upgrade winter/wn-backend-module to 1.2.14 or later.

## Is GHSA-5cwr-5jxg-pcf6 being exploited?

There is no known exploitation of GHSA-5cwr-5jxg-pcf6 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-5cwr-5jxg-pcf6 and fix it if it is affected.

What it is: GHSA-5cwr-5jxg-pcf6 is a cross-site scripting vulnerability in winter/wn-backend-module, published on 20 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-5cwr-5jxg-pcf6 in the wild and no public exploit code.

Affected packages and fixed versions:
- winter/wn-backend-module (Packagist): affected all versions; fixed in 1.2.14
- winter/wn-backend-module (Packagist): affected all versions; fixed in 1.2.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-5cwr-5jxg-pcf6/ (Markdown: https://insights.sbomify.com/GHSA-5cwr-5jxg-pcf6/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-5cwr-5jxg-pcf6

---
From sbomify Insights: https://insights.sbomify.com/GHSA-5cwr-5jxg-pcf6/
Summaries are generated and may contain mistakes; the official description above is the record.
