{"answers":{"affected":"2 open source packages ship an affected version, including mysql.","exploited":"There is no known exploitation of GHSA-5f7m-mmpc-qhh4 in the wild and no public exploit code.","fix":"Upgrade mysql to 2.14.0 or later.","what":"GHSA-5f7m-mmpc-qhh4 is a vulnerability in mysql, published on 23 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-5f7m-mmpc-qhh4 and fix it if it is affected.\n\nWhat it is: GHSA-5f7m-mmpc-qhh4 is a vulnerability in mysql, published on 23 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-5f7m-mmpc-qhh4 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mysql (npm): affected from 2.0.0-alpha8; fixed in 2.14.0\n- mysql (npm): affected from 2.0.0-alpha8; fixed in 2.14.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-5f7m-mmpc-qhh4/ (Markdown: https://insights.sbomify.com/GHSA-5f7m-mmpc-qhh4/index.md)","id":"GHSA-5f7m-mmpc-qhh4","markdown":"https://insights.sbomify.com/GHSA-5f7m-mmpc-qhh4/index.md","name":"GHSA-5f7m-mmpc-qhh4","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js MySQL client","requires_auth":"none","summary":"An attacker can cause the mysql Node.js library to leak uninitialized memory over the network by providing a numeric password.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `mysql` before 2.14.0 are vulnerable to remove memory exposure.\n\nAffected versions of `mysql` package allocate and send an uninitialized memory over the network when a number is provided as a password.\n\nOnly `mysql` running on Node.js versions below 6.0.0 are affected due to a throw added in newer node.js versions.\n\nProof of Concept:\n\n```\nrequire('mysql').createConnection({\n  host: 'localhost',\n  user: 'user',\n  password : USERPROVIDEDINPUT,  // number\n  database : 'my_db'\n}).connect();\n```\n\n## Recommendation\n\nUpdate to version 2.14.0 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"mysql Node.JS Module Vulnerable to Remote Memory Exposure","id":"GHSA-5f7m-mmpc-qhh4","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2.14.0"],"introduced":["2.0.0-alpha8"],"last_affected":[],"package":"mysql","purl":null,"source":"GHSA-5f7m-mmpc-qhh4"},{"ecosystem":"npm","fixed":["2.14.0"],"introduced":["2.0.0-alpha8"],"last_affected":[],"package":"mysql","purl":"pkg:npm/mysql","source":"GHSA-5f7m-mmpc-qhh4"}],"products":null,"published":"2019-05-23","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can cause the mysql Node.js library to leak uninitialized memory over the network by providing a numeric password.","url":"https://insights.sbomify.com/GHSA-5f7m-mmpc-qhh4/"}