# GHSA-5f7m-mmpc-qhh4: mysql Node.JS Module Vulnerable to Remote Memory Exposure

> An attacker can cause the mysql Node.js library to leak uninitialized memory over the network by providing a numeric password.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 May 2019

## What is GHSA-5f7m-mmpc-qhh4?

GHSA-5f7m-mmpc-qhh4 is a vulnerability in mysql, published on 23 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of `mysql` before 2.14.0 are vulnerable to remove memory exposure.

Affected versions of `mysql` package allocate and send an uninitialized memory over the network when a number is provided as a password.

Only `mysql` running on Node.js versions below 6.0.0 are affected due to a throw added in newer node.js versions.

Proof of Concept:

```
require('mysql').createConnection({
  host: 'localhost',
  user: 'user',
  password : USERPROVIDEDINPUT,  // number
  database : 'my_db'
}).connect();
```

## Recommendation

Update to version 2.14.0 or later.

## Which versions are affected by GHSA-5f7m-mmpc-qhh4?

2 open source packages ship an affected version, including mysql.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mysql` | npm | From 2.0.0-alpha8 | 2.14.0 |
| `mysql` | npm | From 2.0.0-alpha8 | 2.14.0 |

## How do I fix GHSA-5f7m-mmpc-qhh4?

Upgrade mysql to 2.14.0 or later.

## Is GHSA-5f7m-mmpc-qhh4 being exploited?

There is no known exploitation of GHSA-5f7m-mmpc-qhh4 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-5f7m-mmpc-qhh4 and fix it if it is affected.

What it is: GHSA-5f7m-mmpc-qhh4 is a vulnerability in mysql, published on 23 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-5f7m-mmpc-qhh4 in the wild and no public exploit code.

Affected packages and fixed versions:
- mysql (npm): affected from 2.0.0-alpha8; fixed in 2.14.0
- mysql (npm): affected from 2.0.0-alpha8; fixed in 2.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-5f7m-mmpc-qhh4/ (Markdown: https://insights.sbomify.com/GHSA-5f7m-mmpc-qhh4/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-5f7m-mmpc-qhh4

---
From sbomify Insights: https://insights.sbomify.com/GHSA-5f7m-mmpc-qhh4/
Summaries are generated and may contain mistakes; the official description above is the record.
