{"answers":{"affected":"2 open source packages ship an affected version, including node-red.","exploited":"There is no known exploitation of GHSA-5g6j-8hv4-vfgj in the wild and no public exploit code.","fix":"Upgrade node-red to 0.18.6 or later.","what":"GHSA-5g6j-8hv4-vfgj is a cross-site scripting vulnerability in node-red, published on 11 Sep 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-5g6j-8hv4-vfgj and fix it if it is affected.\n\nWhat it is: GHSA-5g6j-8hv4-vfgj is a cross-site scripting vulnerability in node-red, published on 11 Sep 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-5g6j-8hv4-vfgj in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- node-red (npm): affected all versions; fixed in 0.18.6\n- node-red (npm): affected all versions; fixed in 0.18.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-5g6j-8hv4-vfgj/ (Markdown: https://insights.sbomify.com/GHSA-5g6j-8hv4-vfgj/index.md)","id":"GHSA-5g6j-8hv4-vfgj","markdown":"https://insights.sbomify.com/GHSA-5g6j-8hv4-vfgj/index.md","name":"GHSA-5g6j-8hv4-vfgj","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node-RED flow editor","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts via unsanitized item names, leading to arbitrary JavaScript execution in victim browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `node-red` prior to 0.18.6 are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize the `name` field in new items, allowing attackers to execute arbitrary JavaScript in the victim's browser.\n\n## Recommendation\n\nUpgrade to version 0.18.6 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross-Site Scripting in node-red","id":"GHSA-5g6j-8hv4-vfgj","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.18.6"],"introduced":["0"],"last_affected":[],"package":"node-red","purl":null,"source":"GHSA-5g6j-8hv4-vfgj"},{"ecosystem":"npm","fixed":["0.18.6"],"introduced":["0"],"last_affected":[],"package":"node-red","purl":"pkg:npm/node-red","source":"GHSA-5g6j-8hv4-vfgj"}],"products":null,"published":"2020-09-11","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can inject malicious scripts via unsanitized item names, leading to arbitrary JavaScript execution in victim browsers.","url":"https://insights.sbomify.com/GHSA-5g6j-8hv4-vfgj/"}