{"answers":{"affected":"2 open source packages ship an affected version, including zendframework/zendframework.","exploited":"There is no known exploitation of GHSA-5gmf-3c43-q73v in the wild and no public exploit code.","fix":"Upgrade zendframework/zendframework to 2.0.1 or later.","what":"GHSA-5gmf-3c43-q73v is a cross-site scripting vulnerability in zendframework/zendframework, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-5gmf-3c43-q73v and fix it if it is affected.\n\nWhat it is: GHSA-5gmf-3c43-q73v is a cross-site scripting vulnerability in zendframework/zendframework, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-5gmf-3c43-q73v in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zendframework/zendframework (Packagist): affected from 2.0.0; fixed in 2.0.1\n- zendframework/zendframework (Packagist): affected from 2.0.0; fixed in 2.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-5gmf-3c43-q73v/ (Markdown: https://insights.sbomify.com/GHSA-5gmf-3c43-q73v/index.md)","id":"GHSA-5gmf-3c43-q73v","markdown":"https://insights.sbomify.com/GHSA-5gmf-3c43-q73v/index.md","name":"GHSA-5gmf-3c43-q73v","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP web framework","requires_auth":"none","summary":"Insufficient escaping in Zend Framework components allows attackers to execute Cross-Site Scripting attacks against users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"`Zend\\Debug`, `Zend\\Feed\\PubSubHubbub`, `Zend\\Log\\Formatter\\Xml`, `Zend\\Tag\\Cloud\\Decorator`, `Zend\\Uri`, `Zend\\View\\Helper\\HeadStyle, Zend\\View\\Helper\\Navigation\\Sitemap`, and `Zend\\View\\Helper\\Placeholder\\Container\\AbstractStandalone` were not using `Zend\\Escaper` when escaping HTML, HTML attributes, and/or URLs. While most were performing some escaping, because they were not using context-appropriate escaping mechanisms, they could potentially be exploited to perform Cross Site Scripting (XSS) attacks.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"ZendFramework vulnerable to Cross-site Scripting","id":"GHSA-5gmf-3c43-q73v","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["2.0.1"],"introduced":["2.0.0"],"last_affected":[],"package":"zendframework/zendframework","purl":null,"source":"GHSA-5gmf-3c43-q73v"},{"ecosystem":"Packagist","fixed":["2.0.1"],"introduced":["2.0.0"],"last_affected":[],"package":"zendframework/zendframework","purl":"pkg:composer/zendframework/zendframework","source":"GHSA-5gmf-3c43-q73v"}],"products":null,"published":"2024-06-07","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Insufficient escaping in Zend Framework components allows attackers to execute Cross-Site Scripting attacks against users.","url":"https://insights.sbomify.com/GHSA-5gmf-3c43-q73v/"}