{"answers":{"affected":"2 open source packages ship an affected version, including @grackle-ai/server.","exploited":"There is no known exploitation of GHSA-5j35-xr4g-vwf4 in the wild and no public exploit code.","fix":"Upgrade @grackle-ai/server to 0.70.5 or later.","what":"GHSA-5j35-xr4g-vwf4 is a vulnerability in @grackle-ai/server, published on 25 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-5j35-xr4g-vwf4 and fix it if it is affected.\n\nWhat it is: GHSA-5j35-xr4g-vwf4 is a vulnerability in @grackle-ai/server, published on 25 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-5j35-xr4g-vwf4 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @grackle-ai/server (npm): affected all versions; fixed in 0.70.5\n- @grackle-ai/server (npm): affected all versions; fixed in 0.70.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-5j35-xr4g-vwf4/ (Markdown: https://insights.sbomify.com/GHSA-5j35-xr4g-vwf4/index.md)","id":"GHSA-5j35-xr4g-vwf4","markdown":"https://insights.sbomify.com/GHSA-5j35-xr4g-vwf4/index.md","name":"GHSA-5j35-xr4g-vwf4","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js server package","requires_auth":"none","summary":"Attackers can intercept session cookies over HTTP when the server is exposed to the network, potentially leading to account takeover.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nThe session cookie is set with `HttpOnly; SameSite=Lax; Path=/` but does not include the `Secure` flag. This means the cookie will be sent over plain HTTP connections.\n\nSince the server binds to `127.0.0.1` by default and uses HTTP (not HTTPS), this is acceptable for localhost use. However, when `--allow-network` is used to bind to `0.0.0.0`, cookies could be transmitted over insecure network connections and intercepted by an attacker.\n\n**Affected code:**\n- `packages/server/src/session.ts:76` — cookie string lacks `; Secure` attribute\n\n### Patches\n\n0.70.5\n\n**Fix:** Conditionally add `; Secure` when served over HTTPS or when `--allow-network` is enabled:\n```typescript\nconst securePart = isHttps ? \"; Secure\" : \"\";\nreturn `${SESSION_COOKIE_NAME}=${cookieValue}; HttpOnly; SameSite=Lax; Path=/${securePart}; Max-Age=${maxAge}`;\n```\n\n### Workarounds\n\nDo not use `--allow-network` over untrusted networks without a TLS-terminating reverse proxy.\n\n### Resources\n\n- OWASP: Secure Cookie Attribute\n- File: `packages/server/src/session.ts`","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"@grackle-ai/server has a Missing Secure Flag on Session Cookie","id":"GHSA-5j35-xr4g-vwf4","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.70.5"],"introduced":["0"],"last_affected":[],"package":"@grackle-ai/server","purl":null,"source":"GHSA-5j35-xr4g-vwf4"},{"ecosystem":"npm","fixed":["0.70.5"],"introduced":["0"],"last_affected":[],"package":"@grackle-ai/server","purl":"pkg:npm/%40grackle-ai/server","source":"GHSA-5j35-xr4g-vwf4"}],"products":null,"published":"2026-03-25","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can intercept session cookies over HTTP when the server is exposed to the network, potentially leading to account takeover.","url":"https://insights.sbomify.com/GHSA-5j35-xr4g-vwf4/"}