# GHSA-5j5w-g665-5m35: Ambiguous OCI manifest parsing

> Ambiguous OCI manifest parsing allows attackers to bypass digest verification, potentially leading to code execution or security bypass in containerd.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Nov 2021
- **Also known as:** GO-2022-0360

## What is GHSA-5j5w-g665-5m35?

GHSA-5j5w-g665-5m35 is an unsafe deserialization vulnerability in github.com/containerd/containerd, published on 18 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Impact

In the OCI Distribution Specification version 1.0.0 and prior and in the OCI Image Specification version 1.0.1 and prior, manifest and index documents are ambiguous without an accompanying Content-Type HTTP header.  Versions of containerd prior to 1.4.12 and 1.5.8 treat the Content-Type header as trusted and deserialize the document according to that header.  If the Content-Type header changed between pulls of the same ambiguous document (with the same digest), the document may be interpreted differently, meaning that the digest alone is insufficient to unambiguously identify the content of the image.

### Patches

This issue has been fixed in containerd 1.4.12 and 1.5.8.  Image pulls for manifests that contain a “manifests” field or indices which contain a “layers” field are rejected.

### Workarounds

Ensure you only pull images from trusted sources.

### References

https://github.com/opencontainers/distribution-spec/security/advisories/GHSA-mc8v-mgrf-8f4m
https://github.com/opencontainers/image-spec/security/advisories/GHSA-77vh-xpmg-72qh

### For more information
If you have any questions or comments about this advisory:
* Open an issue in [containerd](https://github.com/containerd/containerd/issues/new/choose)
* Email us at [security@containerd.io](mailto:security@containerd.io)

## Which versions are affected by GHSA-5j5w-g665-5m35?

5 open source packages ship an affected version, including github.com/containerd/containerd.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containerd/containerd` | Go | All versions | 1.4.12, 1.5.8 |
| `github.com/containerd/containerd` | Go | All versions | 1.4.12 |
| `github.com/containerd/containerd` | Go | All versions | 1.4.12 |
| `github.com/containerd/containerd` | Go | From 1.5.0 | 1.5.8 |
| `github.com/containerd/containerd` | Go | From 1.5.0 | 1.5.8 |

## How do I fix GHSA-5j5w-g665-5m35?

Upgrade github.com/containerd/containerd to a fixed version for your release line: 1.4.12 or 1.5.8.

## Is GHSA-5j5w-g665-5m35 being exploited?

There is no known exploitation of GHSA-5j5w-g665-5m35 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-5j5w-g665-5m35 and fix it if it is affected.

What it is: GHSA-5j5w-g665-5m35 is an unsafe deserialization vulnerability in github.com/containerd/containerd, published on 18 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-5j5w-g665-5m35 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/containerd/containerd (Go): affected all versions; fixed in 1.4.12, 1.5.8
- github.com/containerd/containerd (Go): affected all versions; fixed in 1.4.12
- github.com/containerd/containerd (Go): affected all versions; fixed in 1.4.12
- github.com/containerd/containerd (Go): affected from 1.5.0; fixed in 1.5.8
- github.com/containerd/containerd (Go): affected from 1.5.0; fixed in 1.5.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-5j5w-g665-5m35/ (Markdown: https://insights.sbomify.com/GHSA-5j5w-g665-5m35/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-5j5w-g665-5m35

---
From sbomify Insights: https://insights.sbomify.com/GHSA-5j5w-g665-5m35/
Summaries are generated and may contain mistakes; the official description above is the record.
