{"answers":{"affected":"2 open source packages ship an affected version, including litellm.","exploited":"There is no known exploitation of GHSA-5mg7-485q-xm76 in the wild and no public exploit code.","fix":"No fix has been published for GHSA-5mg7-485q-xm76 yet. Limit exposure of the affected software until one is available.","what":"GHSA-5mg7-485q-xm76 is a vulnerability in litellm, published on 25 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-5mg7-485q-xm76 and fix it if it is affected.\n\nWhat it is: GHSA-5mg7-485q-xm76 is a vulnerability in litellm, published on 25 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-5mg7-485q-xm76 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- litellm (PyPI): affected from 1.82.7 up to 1.82.8; no fix listed\n- litellm (PyPI): affected from 1.82.7 up to 1.82.8; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-5mg7-485q-xm76/ (Markdown: https://insights.sbomify.com/GHSA-5mg7-485q-xm76/index.md)","id":"GHSA-5mg7-485q-xm76","markdown":"https://insights.sbomify.com/GHSA-5mg7-485q-xm76/index.md","name":"GHSA-5mg7-485q-xm76","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python LLM library","requires_auth":"none","summary":"Malicious versions of the LiteLLM library were published to PyPI, harvesting and exfiltrating sensitive credentials from users who installed them.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"After an API Token exposure from an exploited trivy dependency, two new releases of `litellm` were uploaded to PyPI containing automatically activated malware, harvesting sensitive credentials and files, and exfiltrating to a remote API.\n\nAnyone who has installed and run the project should assume any credentials available to litellm environment may have been exposed, and revoke/rotate thema ccordingly.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":false,"headline":"Two LiteLLM versions published containing credential harvesting malware","id":"GHSA-5mg7-485q-xm76","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"supply_chain","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["1.82.7"],"last_affected":["1.82.8"],"package":"litellm","purl":null,"source":"GHSA-5mg7-485q-xm76"},{"ecosystem":"PyPI","fixed":[],"introduced":["1.82.7"],"last_affected":["1.82.8"],"package":"litellm","purl":"pkg:pypi/litellm","source":"GHSA-5mg7-485q-xm76"}],"products":null,"published":"2026-03-25","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Malicious versions of the LiteLLM library were published to PyPI, harvesting and exfiltrating sensitive credentials from users who installed them.","url":"https://insights.sbomify.com/GHSA-5mg7-485q-xm76/"}