{"answers":{"affected":"2 open source packages ship an affected version, including wallabag/wallabag.","exploited":"There is no known exploitation of GHSA-5pm7-cp8f-p2c2 in the wild and no public exploit code.","fix":"Upgrade wallabag/wallabag to 2.6.11 or later.","what":"GHSA-5pm7-cp8f-p2c2 is a vulnerability in wallabag/wallabag, published on 9 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-5pm7-cp8f-p2c2 and fix it if it is affected.\n\nWhat it is: GHSA-5pm7-cp8f-p2c2 is a vulnerability in wallabag/wallabag, published on 9 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-5pm7-cp8f-p2c2 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wallabag/wallabag (Packagist): affected all versions; fixed in 2.6.11\n- wallabag/wallabag (Packagist): affected all versions; fixed in 2.6.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-5pm7-cp8f-p2c2/ (Markdown: https://insights.sbomify.com/GHSA-5pm7-cp8f-p2c2/index.md)","id":"GHSA-5pm7-cp8f-p2c2","markdown":"https://insights.sbomify.com/GHSA-5pm7-cp8f-p2c2/index.md","name":"GHSA-5pm7-cp8f-p2c2","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"wallabag self-hosted app","requires_auth":"low_privilege","summary":"Attackers can trick logged-in wallabag users into performing unintended actions like deleting entries or managing tokens via crafted links.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Impact\n\nwallabag versions prior to 2.6.11 were discovered to contain multiple Cross-Site Request Forgery (CSRF) vulnerabilities across several endpoints. An attacker could craft a malicious link or page that, if visited by a logged-in wallabag user, could trick the user's browser into performing unintended actions within their wallabag account without their consent. Additionally, one endpoint affects the login page locale setting.\n\nThe affected endpoints allow attackers to potentially perform actions such as:\n\n* **Manage API Tokens:**\n    * `/generate-token`\n    * `/revoke-token`\n* **Manage User Rules:**\n    * `/tagging-rule/delete/{taggingRule}`\n    * `/ignore-origin-user-rule/delete/{ignoreOriginUserRule}`\n* **Modify User Configuration:**\n    * `/config/view-mode`\n* **Manage Individual Entries:**\n    * `/reload/{id}`\n    * `/archive/{id}`\n    * `/star/{id}`\n    * `/delete/{id}`\n    * `/share/{id}`\n    * `/share/delete/{id}`\n* **Manage Tags:**\n    * `/remove-tag/{entry}/{tag}`\n    * `/tag/search/{filter}`\n    * `/tag/delete/{slug}`\n* **Perform Bulk Actions:**\n    * `/mass`\n* **Change Interface Language (Login Page):**\n    * `/locale/{language}`\n\nSuccessfully exploiting these vulnerabilities could lead to unauthorized modification or deletion of user data, configuration changes, token manipulation, or interface changes, depending on the specific endpoint targeted.\n\nThis set of vulnerabilities has an aggregated CVSS v3.1 score of 4.3 (Medium).\n\n**Users are strongly advised to upgrade their wallabag instance to version 2.6.11 or later to mitigate these vulnerabilities.**\n\n## Resolution\n\nThese vulnerabilities have been addressed in wallabag version **2.6.11**. The affected endpoints have been modified to require the HTTP POST method along with a valid CSRF token for state-changing actions, preventing attackers from forcing users' browsers to perform these actions unintentionally.\n\n## Credits\n\nFound, reported and fixed by @yguedidi","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"wallabag/wallabag Has Multiple Cross-Site Request Forgery (CSRF) Vulnerabilities","id":"GHSA-5pm7-cp8f-p2c2","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"csrf","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["2.6.11"],"introduced":["0"],"last_affected":[],"package":"wallabag/wallabag","purl":null,"source":"GHSA-5pm7-cp8f-p2c2"},{"ecosystem":"Packagist","fixed":["2.6.11"],"introduced":["0"],"last_affected":[],"package":"wallabag/wallabag","purl":"pkg:composer/wallabag/wallabag","source":"GHSA-5pm7-cp8f-p2c2"}],"products":null,"published":"2025-04-09","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can trick logged-in wallabag users into performing unintended actions like deleting entries or managing tokens via crafted links.","url":"https://insights.sbomify.com/GHSA-5pm7-cp8f-p2c2/"}