# GHSA-5pm7-cp8f-p2c2: wallabag/wallabag Has Multiple Cross-Site Request Forgery (CSRF) Vulnerabilities

> Attackers can trick logged-in wallabag users into performing unintended actions like deleting entries or managing tokens via crafted links.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Apr 2025

## What is GHSA-5pm7-cp8f-p2c2?

GHSA-5pm7-cp8f-p2c2 is a vulnerability in wallabag/wallabag, published on 9 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

## Impact

wallabag versions prior to 2.6.11 were discovered to contain multiple Cross-Site Request Forgery (CSRF) vulnerabilities across several endpoints. An attacker could craft a malicious link or page that, if visited by a logged-in wallabag user, could trick the user's browser into performing unintended actions within their wallabag account without their consent. Additionally, one endpoint affects the login page locale setting.

The affected endpoints allow attackers to potentially perform actions such as:

* **Manage API Tokens:**
    * `/generate-token`
    * `/revoke-token`
* **Manage User Rules:**
    * `/tagging-rule/delete/{taggingRule}`
    * `/ignore-origin-user-rule/delete/{ignoreOriginUserRule}`
* **Modify User Configuration:**
    * `/config/view-mode`
* **Manage Individual Entries:**
    * `/reload/{id}`
    * `/archive/{id}`
    * `/star/{id}`
    * `/delete/{id}`
    * `/share/{id}`
    * `/share/delete/{id}`
* **Manage Tags:**
    * `/remove-tag/{entry}/{tag}`
    * `/tag/search/{filter}`
    * `/tag/delete/{slug}`
* **Perform Bulk Actions:**
    * `/mass`
* **Change Interface Language (Login Page):**
    * `/locale/{language}`

Successfully exploiting these vulnerabilities could lead to unauthorized modification or deletion of user data, configuration changes, token manipulation, or interface changes, depending on the specific endpoint targeted.

This set of vulnerabilities has an aggregated CVSS v3.1 score of 4.3 (Medium).

**Users are strongly advised to upgrade their wallabag instance to version 2.6.11 or later to mitigate these vulnerabilities.**

## Resolution

These vulnerabilities have been addressed in wallabag version **2.6.11**. The affected endpoints have been modified to require the HTTP POST method along with a valid CSRF token for state-changing actions, preventing attackers from forcing users' browsers to perform these actions unintentionally.

## Credits

Found, reported and fixed by @yguedidi

## Which versions are affected by GHSA-5pm7-cp8f-p2c2?

2 open source packages ship an affected version, including wallabag/wallabag.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wallabag/wallabag` | Packagist | All versions | 2.6.11 |
| `wallabag/wallabag` | Packagist | All versions | 2.6.11 |

## How do I fix GHSA-5pm7-cp8f-p2c2?

Upgrade wallabag/wallabag to 2.6.11 or later.

## Is GHSA-5pm7-cp8f-p2c2 being exploited?

There is no known exploitation of GHSA-5pm7-cp8f-p2c2 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-5pm7-cp8f-p2c2 and fix it if it is affected.

What it is: GHSA-5pm7-cp8f-p2c2 is a vulnerability in wallabag/wallabag, published on 9 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-5pm7-cp8f-p2c2 in the wild and no public exploit code.

Affected packages and fixed versions:
- wallabag/wallabag (Packagist): affected all versions; fixed in 2.6.11
- wallabag/wallabag (Packagist): affected all versions; fixed in 2.6.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-5pm7-cp8f-p2c2/ (Markdown: https://insights.sbomify.com/GHSA-5pm7-cp8f-p2c2/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-5pm7-cp8f-p2c2

---
From sbomify Insights: https://insights.sbomify.com/GHSA-5pm7-cp8f-p2c2/
Summaries are generated and may contain mistakes; the official description above is the record.
