# GHSA-5pmx-7r6r-wfqq: Kgateway transformation policy template can emit files from the container

> Users with TrafficPolicy creation permissions can read arbitrary files from the dataplane container filesystem via crafted transformation templates.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Nov 2025
- **Also known as:** GO-2025-4095

## What is GHSA-5pmx-7r6r-wfqq?

GHSA-5pmx-7r6r-wfqq is a path traversal vulnerability in github.com/kgateway-dev/kgateway, published on 4 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

## Summary

The transformation policy template feature in Kgateway versions through 2.0.4 allows users with TrafficPolicy creation permissions to craft transformations that read and expose arbitrary files from the dataplane container filesystem.

## Description

### Impact

Users with permissions to create a TrafficPolicy can create a transformation that returns files from within the dataplane container. While no secrets are mounted to the container by default, users who mount custom volumes to the dataplane should be aware of potential data exposure through this vulnerability.

This could allow unauthorized access to:
- Configuration files within the container
- Custom mounted volumes and their contents
- Any files accessible to the dataplane container process

Note: Updated availability score to high, as under some configurations this can prevent xDS updates.

### Patches

Upgrade to version 2.0.5 or 2.1.0. These versions include an updated transformation filter in envoy-gloo that prevents file access through transformation templates.

### Workarounds

If you are not using transformations, you can disallow TrafficPolicy creation or restrict transformation usage using a ValidatingAdmissionPolicy to prevent exploitation while preparing to upgrade.

## References

- Fix in 2.1.0: https://github.com/kgateway-dev/kgateway/pull/12528 (envoy-gloo v1.35.2-patch4)
- Backport to 2.0.5: Included in https://github.com/kgateway-dev/kgateway/pull/12535 (envoy-gloo v1.34.6-patch3)
- Envoy-gloo releases: https://github.com/solo-io/envoy-gloo/releases/tag/v1.35.2-patch4
- Envoy-gloo releases: https://github.com/solo-io/envoy-gloo/releases/tag/v1.34.6-patch3

## Credits

Kindly reported by @rikatz

## For More Information

If you have any questions or comments about this advisory, please reach out in slack https://cloud-native.slack.com/archives/C080D3PJMS4

## Which versions are affected by GHSA-5pmx-7r6r-wfqq?

6 open source packages ship an affected version, including github.com/kgateway-dev/kgateway/v2 and github.com/kgateway-dev/kgateway.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kgateway-dev/kgateway/v2` | Go | All versions | 2.0.5, 2.1.0 |
| `github.com/kgateway-dev/kgateway/v2` | Go | All versions | 2.0.5 |
| `github.com/kgateway-dev/kgateway/v2` | Go | All versions | 2.0.5 |
| `github.com/kgateway-dev/kgateway/v2` | Go | From 2.1.0-agw-cel-rbac | 2.1.0 |
| `github.com/kgateway-dev/kgateway/v2` | Go | From 2.1.0-agw-cel-rbac | 2.1.0 |
| `github.com/kgateway-dev/kgateway` | Go | All versions | None |

## How do I fix GHSA-5pmx-7r6r-wfqq?

Upgrade github.com/kgateway-dev/kgateway/v2 to a fixed version for your release line: 2.0.5 or 2.1.0.

## Is GHSA-5pmx-7r6r-wfqq being exploited?

There is no known exploitation of GHSA-5pmx-7r6r-wfqq in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-5pmx-7r6r-wfqq and fix it if it is affected.

What it is: GHSA-5pmx-7r6r-wfqq is a path traversal vulnerability in github.com/kgateway-dev/kgateway, published on 4 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-5pmx-7r6r-wfqq in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/kgateway-dev/kgateway/v2 (Go): affected all versions; fixed in 2.0.5, 2.1.0
- github.com/kgateway-dev/kgateway/v2 (Go): affected all versions; fixed in 2.0.5
- github.com/kgateway-dev/kgateway/v2 (Go): affected all versions; fixed in 2.0.5
- github.com/kgateway-dev/kgateway/v2 (Go): affected from 2.1.0-agw-cel-rbac; fixed in 2.1.0
- github.com/kgateway-dev/kgateway/v2 (Go): affected from 2.1.0-agw-cel-rbac; fixed in 2.1.0
- github.com/kgateway-dev/kgateway (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-5pmx-7r6r-wfqq/ (Markdown: https://insights.sbomify.com/GHSA-5pmx-7r6r-wfqq/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-5pmx-7r6r-wfqq

---
From sbomify Insights: https://insights.sbomify.com/GHSA-5pmx-7r6r-wfqq/
Summaries are generated and may contain mistakes; the official description above is the record.
