GHSA-5q58-x5h2-v5rx Authenticated Privilege Escalation
Authenticated users can escalate privileges in Shopware 6, allowing unauthorized access to higher-level administrative functions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-5q58-x5h2-v5rx?
GHSA-5q58-x5h2-v5rx is a vulnerability in shopware/core, published on 21 Dec 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Impact
Authenticated Privilege Escalation
Patches
We recommend to update to the current version 6.3.4.1. You can get the update to 6.3.4.1 regularly via the Auto-Updater or directly via the download overview.
https://www.shopware.com/en/download/#shopware-6
Workarounds
For older versions of 6.1 and 6.2 the corresponding changes are also available via plugin:
https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659
For more information
https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-12-2020
Which versions are affected by GHSA-5q58-x5h2-v5rx?
4 open source packages ship an affected version, including shopware/core and shopware/platform.
| Package | Affected | Fixed in |
|---|---|---|
shopware/core Packagist | All versions | 6.3.4.1 |
shopware/core Packagist | All versions | 6.3.4.1 |
shopware/platform Packagist | All versions | 6.3.4.1 |
shopware/platform Packagist | All versions | 6.3.4.1 |
How do I fix GHSA-5q58-x5h2-v5rx?
Upgrade shopware/core to 6.3.4.1 or later.
Is GHSA-5q58-x5h2-v5rx being exploited?
There is no known exploitation of GHSA-5q58-x5h2-v5rx in the wild and no public exploit code.