{"answers":{"affected":"2 open source packages ship an affected version, including activerecord-jdbc-adapter.","exploited":"There is no known exploitation of GHSA-5qw5-wf2q-f538 in the wild and no public exploit code.","fix":"Upgrade activerecord-jdbc-adapter to 1.2.8 or later.","what":"GHSA-5qw5-wf2q-f538 is a SQL injection vulnerability in activerecord-jdbc-adapter, published on 16 Jan 2026. It can be exploited over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-5qw5-wf2q-f538 and fix it if it is affected.\n\nWhat it is: GHSA-5qw5-wf2q-f538 is a SQL injection vulnerability in activerecord-jdbc-adapter, published on 16 Jan 2026. It can be exploited over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-5qw5-wf2q-f538 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- activerecord-jdbc-adapter (RubyGems): affected all versions; fixed in 1.2.8\n- activerecord-jdbc-adapter (RubyGems): affected all versions; fixed in 1.2.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-5qw5-wf2q-f538/ (Markdown: https://insights.sbomify.com/GHSA-5qw5-wf2q-f538/index.md)","id":"GHSA-5qw5-wf2q-f538","markdown":"https://insights.sbomify.com/GHSA-5qw5-wf2q-f538/index.md","name":"GHSA-5qw5-wf2q-f538","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby JDBC adapter","requires_auth":"unknown","summary":"Remote attackers can inject SQL via unsanitized input in the ActiveRecord-JDBC-Adapter, leading to data manipulation or disclosure.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"ActiveRecord-JDBC-Adapter (AR-JDBC) contains a flaw that may allow carrying out an SQL injection attack. The issue is due to the sql.gsub() function in lib/arjdbc/jdbc/adapter.rb not properly sanitizing user-supplied input before using it in SQL queries. This may allow a remote attacker to inject or manipulate SQL queries in the back-end database, allowing for the manipulation or disclosure of arbitrary data.","ecosystems":["RubyGems"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"ActiveRecord-JDBC-Adapter (AR-JDBC) lib/arjdbc/jdbc/adapter.rb sql.gsub() Function SQL Injection","id":"GHSA-5qw5-wf2q-f538","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"sql_injection","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"RubyGems","fixed":["1.2.8"],"introduced":["0"],"last_affected":[],"package":"activerecord-jdbc-adapter","purl":null,"source":"GHSA-5qw5-wf2q-f538"},{"ecosystem":"RubyGems","fixed":["1.2.8"],"introduced":["0"],"last_affected":[],"package":"activerecord-jdbc-adapter","purl":"pkg:gem/activerecord-jdbc-adapter","source":"GHSA-5qw5-wf2q-f538"}],"products":null,"published":"2026-01-16","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Remote attackers can inject SQL via unsanitized input in the ActiveRecord-JDBC-Adapter, leading to data manipulation or disclosure.","url":"https://insights.sbomify.com/GHSA-5qw5-wf2q-f538/"}