GHSA-5rjc-jc28-cwgg Connect-CMS Access control vulnerability
An access control flaw in Connect-CMS allows unauthorized users to access management functions, requiring an upgrade to secure the system.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-5rjc-jc28-cwgg?
GHSA-5rjc-jc28-cwgg is a missing authorization vulnerability in opensource-workshop/connect-cms, published on 7 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Impact(影響)
There is an Access control vulnerability on the management system of Connect-CMS. Affected Version : Connect-CMS v1.8.6, 2.4.6 and earlier
Patches(修正バージョン)
version v1.8.7, v2.4.7
Workarounds(運用回避手段)
Upgrade Connect-CMS to latest version
Which versions are affected by GHSA-5rjc-jc28-cwgg?
4 open source packages ship an affected version, including opensource-workshop/connect-cms.
| Package | Affected | Fixed in |
|---|---|---|
opensource-workshop/connect-cms Packagist | All versions | 1.8.7 |
opensource-workshop/connect-cms Packagist | All versions | 1.8.7 |
opensource-workshop/connect-cms Packagist | From 2.0.0 | 2.4.7 |
opensource-workshop/connect-cms Packagist | From 2.0.0 | 2.4.7 |
How do I fix GHSA-5rjc-jc28-cwgg?
Upgrade opensource-workshop/connect-cms to a fixed version for your release line: 1.8.7 or 2.4.7.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is GHSA-5rjc-jc28-cwgg being exploited?
There is no known exploitation of GHSA-5rjc-jc28-cwgg in the wild and no public exploit code.