{"answers":{"affected":"4 open source packages ship an affected version, including opensource-workshop/connect-cms.","exploited":"There is no known exploitation of GHSA-5rjc-jc28-cwgg in the wild and no public exploit code.","fix":"Upgrade opensource-workshop/connect-cms to a fixed version for your release line: 1.8.7 or 2.4.7.","what":"GHSA-5rjc-jc28-cwgg is a missing authorization vulnerability in opensource-workshop/connect-cms, published on 7 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-5rjc-jc28-cwgg and fix it if it is affected.\n\nWhat it is: GHSA-5rjc-jc28-cwgg is a missing authorization vulnerability in opensource-workshop/connect-cms, published on 7 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-5rjc-jc28-cwgg in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- opensource-workshop/connect-cms (Packagist): affected all versions; fixed in 1.8.7\n- opensource-workshop/connect-cms (Packagist): affected all versions; fixed in 1.8.7\n- opensource-workshop/connect-cms (Packagist): affected from 2.0.0; fixed in 2.4.7\n- opensource-workshop/connect-cms (Packagist): affected from 2.0.0; fixed in 2.4.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-5rjc-jc28-cwgg/ (Markdown: https://insights.sbomify.com/GHSA-5rjc-jc28-cwgg/index.md)","id":"GHSA-5rjc-jc28-cwgg","markdown":"https://insights.sbomify.com/GHSA-5rjc-jc28-cwgg/index.md","name":"GHSA-5rjc-jc28-cwgg","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Connect-CMS","requires_auth":"low_privilege","summary":"An access control flaw in Connect-CMS allows unauthorized users to access management functions, requiring an upgrade to secure the system.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact（影響）\n\nThere is an Access control vulnerability on the management system of Connect-CMS.\nAffected Version : Connect-CMS v1.8.6, 2.4.6 and earlier\n\n### Patches（修正バージョン）\n\nversion v1.8.7, v2.4.7\n\n### Workarounds（運用回避手段）\n\nUpgrade Connect-CMS to latest version","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Connect-CMS Access control vulnerability","id":"GHSA-5rjc-jc28-cwgg","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2025"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.8.7"],"introduced":["0"],"last_affected":[],"package":"opensource-workshop/connect-cms","purl":null,"source":"GHSA-5rjc-jc28-cwgg"},{"ecosystem":"Packagist","fixed":["1.8.7"],"introduced":["0"],"last_affected":[],"package":"opensource-workshop/connect-cms","purl":"pkg:composer/opensource-workshop/connect-cms","source":"GHSA-5rjc-jc28-cwgg"},{"ecosystem":"Packagist","fixed":["2.4.7"],"introduced":["2.0.0"],"last_affected":[],"package":"opensource-workshop/connect-cms","purl":null,"source":"GHSA-5rjc-jc28-cwgg"},{"ecosystem":"Packagist","fixed":["2.4.7"],"introduced":["2.0.0"],"last_affected":[],"package":"opensource-workshop/connect-cms","purl":"pkg:composer/opensource-workshop/connect-cms","source":"GHSA-5rjc-jc28-cwgg"}],"products":null,"published":"2025-02-07","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An access control flaw in Connect-CMS allows unauthorized users to access management functions, requiring an upgrade to secure the system.","url":"https://insights.sbomify.com/GHSA-5rjc-jc28-cwgg/"}