# GHSA-5rjc-jc28-cwgg: Connect-CMS Access control vulnerability

> An access control flaw in Connect-CMS allows unauthorized users to access management functions, requiring an upgrade to secure the system.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Feb 2025

## What is GHSA-5rjc-jc28-cwgg?

GHSA-5rjc-jc28-cwgg is a missing authorization vulnerability in opensource-workshop/connect-cms, published on 7 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

### Impact（影響）

There is an Access control vulnerability on the management system of Connect-CMS.
Affected Version : Connect-CMS v1.8.6, 2.4.6 and earlier

### Patches（修正バージョン）

version v1.8.7, v2.4.7

### Workarounds（運用回避手段）

Upgrade Connect-CMS to latest version

## Which versions are affected by GHSA-5rjc-jc28-cwgg?

4 open source packages ship an affected version, including opensource-workshop/connect-cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `opensource-workshop/connect-cms` | Packagist | All versions | 1.8.7 |
| `opensource-workshop/connect-cms` | Packagist | All versions | 1.8.7 |
| `opensource-workshop/connect-cms` | Packagist | From 2.0.0 | 2.4.7 |
| `opensource-workshop/connect-cms` | Packagist | From 2.0.0 | 2.4.7 |

## How do I fix GHSA-5rjc-jc28-cwgg?

Upgrade opensource-workshop/connect-cms to a fixed version for your release line: 1.8.7 or 2.4.7.

## Is GHSA-5rjc-jc28-cwgg being exploited?

There is no known exploitation of GHSA-5rjc-jc28-cwgg in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-5rjc-jc28-cwgg and fix it if it is affected.

What it is: GHSA-5rjc-jc28-cwgg is a missing authorization vulnerability in opensource-workshop/connect-cms, published on 7 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-5rjc-jc28-cwgg in the wild and no public exploit code.

Affected packages and fixed versions:
- opensource-workshop/connect-cms (Packagist): affected all versions; fixed in 1.8.7
- opensource-workshop/connect-cms (Packagist): affected all versions; fixed in 1.8.7
- opensource-workshop/connect-cms (Packagist): affected from 2.0.0; fixed in 2.4.7
- opensource-workshop/connect-cms (Packagist): affected from 2.0.0; fixed in 2.4.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-5rjc-jc28-cwgg/ (Markdown: https://insights.sbomify.com/GHSA-5rjc-jc28-cwgg/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-5rjc-jc28-cwgg

---
From sbomify Insights: https://insights.sbomify.com/GHSA-5rjc-jc28-cwgg/
Summaries are generated and may contain mistakes; the official description above is the record.
