{"answers":{"affected":"4 open source packages ship an affected version, including colors.","exploited":"There is no known exploitation of GHSA-5rqg-jm4f-cqx7 in the wild and no public exploit code.","fix":"No fix has been published for GHSA-5rqg-jm4f-cqx7 yet. Limit exposure of the affected software until one is available.","what":"GHSA-5rqg-jm4f-cqx7 is a denial of service vulnerability in colors, published on 10 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-5rqg-jm4f-cqx7 and fix it if it is affected.\n\nWhat it is: GHSA-5rqg-jm4f-cqx7 is a denial of service vulnerability in colors, published on 10 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-5rqg-jm4f-cqx7 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- colors (npm): affected all versions; no fix listed\n- colors (npm): affected all versions; no fix listed\n- colors (npm): affected from 1.4.1 up to 1.4.2; no fix listed\n- colors (npm): affected from 1.4.1 up to 1.4.2; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-5rqg-jm4f-cqx7/ (Markdown: https://insights.sbomify.com/GHSA-5rqg-jm4f-cqx7/index.md)","id":"GHSA-5rqg-jm4f-cqx7","markdown":"https://insights.sbomify.com/GHSA-5rqg-jm4f-cqx7/index.md","name":"GHSA-5rqg-jm4f-cqx7","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js colors library","requires_auth":"none","summary":"Malicious code in specific versions of the colors library causes an infinite loop, leading to denial of service via resource exhaustion.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"colors is a library for including colored text in node.js consoles. Between 07 and 09 January 2022, colors versions 1.4.1, 1.4.2, and 1.4.44-liberty-2 were published including malicious code that caused a Denial of Service due to an infinite loop. Software dependent on these versions experienced the printing of randomized characters to console and an infinite loop resulting in unbound system resource consumption.\n\nUsers of colors relying on these specific versions should downgrade to version 1.4.0.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":false,"headline":"Infinite loop causing Denial of Service in colors","id":"GHSA-5rqg-jm4f-cqx7","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"npm","fixed":[],"introduced":[],"last_affected":[],"package":"colors","purl":null,"source":"GHSA-5rqg-jm4f-cqx7"},{"ecosystem":"npm","fixed":[],"introduced":[],"last_affected":[],"package":"colors","purl":"pkg:npm/colors","source":"GHSA-5rqg-jm4f-cqx7"},{"ecosystem":"npm","fixed":[],"introduced":["1.4.1"],"last_affected":["1.4.2"],"package":"colors","purl":null,"source":"GHSA-5rqg-jm4f-cqx7"},{"ecosystem":"npm","fixed":[],"introduced":["1.4.1"],"last_affected":["1.4.2"],"package":"colors","purl":"pkg:npm/colors","source":"GHSA-5rqg-jm4f-cqx7"}],"products":null,"published":"2022-01-10","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Malicious code in specific versions of the colors library causes an infinite loop, leading to denial of service via resource exhaustion.","url":"https://insights.sbomify.com/GHSA-5rqg-jm4f-cqx7/"}