GHSA-5vj8-3v2h-h38v Remote Code Execution in next
- Exploited in the wild
- Not known
- Fix
- Available
What is GHSA-5vj8-3v2h-h38v?
GHSA-5vj8-3v2h-h38v is a vulnerability in next, published on 4 Sep 2020.
Official description
Versions of next prior to 5.1.0 are vulnerable to Remote Code Execution. The /path: route fails to properly sanitize input and passes it to a require() call. This allows attackers to execute JavaScript code on the server. Note that prior version 0.9.9 package next npm package hosted a different utility (0.4.1 being the latest version of that codebase), and this advisory does not apply to those versions.
Recommendation
Upgrade to version 5.1.0.
Which versions are affected by GHSA-5vj8-3v2h-h38v?
2 open source packages ship an affected version, including next.
| Package | Affected | Fixed in |
|---|---|---|
next npm | From 0.9.9 | 5.1.0 |
next npm | From 0.9.9 | 5.1.0 |
How do I fix GHSA-5vj8-3v2h-h38v?
Upgrade next to 5.1.0 or later.
Is GHSA-5vj8-3v2h-h38v being exploited?
There is no known exploitation of GHSA-5vj8-3v2h-h38v in the wild and no public exploit code.