{"answers":{"affected":"2 open source packages ship an affected version, including next.","exploited":"There is no known exploitation of GHSA-5vj8-3v2h-h38v in the wild and no public exploit code.","fix":"Upgrade next to 5.1.0 or later.","what":"GHSA-5vj8-3v2h-h38v is a vulnerability in next, published on 4 Sep 2020."},"fix_prompt":"Check this codebase for GHSA-5vj8-3v2h-h38v and fix it if it is affected.\n\nWhat it is: GHSA-5vj8-3v2h-h38v is a vulnerability in next, published on 4 Sep 2020. \nExploitation: There is no known exploitation of GHSA-5vj8-3v2h-h38v in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- next (npm): affected from 0.9.9; fixed in 5.1.0\n- next (npm): affected from 0.9.9; fixed in 5.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-5vj8-3v2h-h38v/ (Markdown: https://insights.sbomify.com/GHSA-5vj8-3v2h-h38v/index.md)","id":"GHSA-5vj8-3v2h-h38v","markdown":"https://insights.sbomify.com/GHSA-5vj8-3v2h-h38v/index.md","name":"GHSA-5vj8-3v2h-h38v","record":{"aliases":[],"analysis":null,"analysis_generated_by":null,"assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `next` prior to 5.1.0 are vulnerable to Remote Code Execution. The `/path:` route fails to properly sanitize input and passes it to a `require()` call. This allows attackers to execute JavaScript code on the server. Note that prior version 0.9.9 package `next` npm package hosted a different utility (0.4.1 being the latest version of that codebase), and this advisory does not apply to those versions.\n\n## Recommendation\n\nUpgrade to version 5.1.0.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Remote Code Execution in next","id":"GHSA-5vj8-3v2h-h38v","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":null,"year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["5.1.0"],"introduced":["0.9.9"],"last_affected":[],"package":"next","purl":null,"source":"GHSA-5vj8-3v2h-h38v"},{"ecosystem":"npm","fixed":["5.1.0"],"introduced":["0.9.9"],"last_affected":[],"package":"next","purl":"pkg:npm/next","source":"GHSA-5vj8-3v2h-h38v"}],"products":null,"published":"2020-09-04","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":null,"url":"https://insights.sbomify.com/GHSA-5vj8-3v2h-h38v/"}