# GHSA-5vj8-3v2h-h38v: Remote Code Execution in next


- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 4 Sep 2020

## What is GHSA-5vj8-3v2h-h38v?

GHSA-5vj8-3v2h-h38v is a vulnerability in next, published on 4 Sep 2020. 

### Official description

Versions of `next` prior to 5.1.0 are vulnerable to Remote Code Execution. The `/path:` route fails to properly sanitize input and passes it to a `require()` call. This allows attackers to execute JavaScript code on the server. Note that prior version 0.9.9 package `next` npm package hosted a different utility (0.4.1 being the latest version of that codebase), and this advisory does not apply to those versions.

## Recommendation

Upgrade to version 5.1.0.

## Which versions are affected by GHSA-5vj8-3v2h-h38v?

2 open source packages ship an affected version, including next.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 0.9.9 | 5.1.0 |
| `next` | npm | From 0.9.9 | 5.1.0 |

## How do I fix GHSA-5vj8-3v2h-h38v?

Upgrade next to 5.1.0 or later.

## Is GHSA-5vj8-3v2h-h38v being exploited?

There is no known exploitation of GHSA-5vj8-3v2h-h38v in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-5vj8-3v2h-h38v and fix it if it is affected.

What it is: GHSA-5vj8-3v2h-h38v is a vulnerability in next, published on 4 Sep 2020. 
Exploitation: There is no known exploitation of GHSA-5vj8-3v2h-h38v in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 0.9.9; fixed in 5.1.0
- next (npm): affected from 0.9.9; fixed in 5.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-5vj8-3v2h-h38v/ (Markdown: https://insights.sbomify.com/GHSA-5vj8-3v2h-h38v/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-5vj8-3v2h-h38v

---
From sbomify Insights: https://insights.sbomify.com/GHSA-5vj8-3v2h-h38v/
Summaries are generated and may contain mistakes; the official description above is the record.
