{"answers":{"affected":"3 open source packages ship an affected version, including capnp.","exploited":"There is no known exploitation of GHSA-5w5r-mf82-595p in the wild and no public exploit code.","fix":"Upgrade capnp to 0.24.0 or later.","what":"GHSA-5w5r-mf82-595p is a memory corruption vulnerability in capnp, published on 24 Dec 2025."},"fix_prompt":"Check this codebase for GHSA-5w5r-mf82-595p and fix it if it is affected.\n\nWhat it is: GHSA-5w5r-mf82-595p is a memory corruption vulnerability in capnp, published on 24 Dec 2025. \nExploitation: There is no known exploitation of GHSA-5w5r-mf82-595p in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- capnp (crates.io): affected all versions; fixed in 0.24.0\n- capnp (crates.io): affected all versions; fixed in 0.24.0\n- capnp (crates.io): affected from 0.0.0-0; fixed in 0.24.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-5w5r-mf82-595p/ (Markdown: https://insights.sbomify.com/GHSA-5w5r-mf82-595p/index.md)","id":"GHSA-5w5r-mf82-595p","markdown":"https://insights.sbomify.com/GHSA-5w5r-mf82-595p/index.md","name":"GHSA-5w5r-mf82-595p","record":{"aliases":["RUSTSEC-2025-0143"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"unknown","non_default_config":false,"product_category":"Rust serialization library","requires_auth":"none","summary":"Unsound APIs in the Rust library allow safe code to trigger undefined behavior, potentially leading to crashes or arbitrary code execution.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"The safe API functions `constant::Reader::get` and `StructSchema::new` rely on `PointerReader::get_root_unchecked`, which can cause undefined behavior (UB) by constructing arbitrary words or schemas.\n\n## `Reader::get`\n\n```rust\npub fn get(\u0026self) -\u003e Result\u003c\u003cT as Owned\u003e::Reader\u003c'static\u003e\u003e {\n    // ...\n    // UNSAFE: access `words` without validation\n}\n```\n\n## `StructSchema::new`\n\n```rust\npub fn new(builder: RawBrandedStructSchema) -\u003e StructSchema {\n    // ...\n    // UNSAFE: access encoded nodes without validation\n}\n```\n\nThis vulnerability allows safe Rust code to trigger UB, which violates Rust's safety guarantees.\n\nThe issue is resolved in version `0.24.0` by making constructor functions unsafe and mark the fields of struct as visible only in the crate.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Unsound APIs of public `constant::Reader` and `StructSchema`","id":"GHSA-5w5r-mf82-595p","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"memory_corruption","year":"2025"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["0.24.0"],"introduced":["0"],"last_affected":[],"package":"capnp","purl":null,"source":"GHSA-5w5r-mf82-595p"},{"ecosystem":"crates.io","fixed":["0.24.0"],"introduced":["0"],"last_affected":[],"package":"capnp","purl":"pkg:cargo/capnp","source":"GHSA-5w5r-mf82-595p"},{"ecosystem":"crates.io","fixed":["0.24.0"],"introduced":["0.0.0-0"],"last_affected":[],"package":"capnp","purl":"pkg:cargo/capnp","source":"RUSTSEC-2025-0143"}],"products":null,"published":"2025-12-24","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Unsound APIs in the Rust library allow safe code to trigger undefined behavior, potentially leading to crashes or arbitrary code execution.","url":"https://insights.sbomify.com/GHSA-5w5r-mf82-595p/"}