{"answers":{"affected":"2 open source packages ship an affected version, including aws-kms-tls-auth.","exploited":"There is no known exploitation of GHSA-5whh-4q9j-7v28 in the wild and no public exploit code.","fix":"Upgrade aws-kms-tls-auth to 0.0.3 or later.","what":"GHSA-5whh-4q9j-7v28 is a denial of service vulnerability in aws-kms-tls-auth, published on 3 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-5whh-4q9j-7v28 and fix it if it is affected.\n\nWhat it is: GHSA-5whh-4q9j-7v28 is a denial of service vulnerability in aws-kms-tls-auth, published on 3 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-5whh-4q9j-7v28 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- aws-kms-tls-auth (crates.io): affected all versions; fixed in 0.0.3\n- aws-kms-tls-auth (crates.io): affected all versions; fixed in 0.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-5whh-4q9j-7v28/ (Markdown: https://insights.sbomify.com/GHSA-5whh-4q9j-7v28/index.md)","id":"GHSA-5whh-4q9j-7v28","markdown":"https://insights.sbomify.com/GHSA-5whh-4q9j-7v28/index.md","name":"GHSA-5whh-4q9j-7v28","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust TLS library","requires_auth":"none","summary":"A memory overallocation flaw in aws-kms-tls-auth allows remote attackers to cause denial of service via crafted TLS handshakes.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Summary\naws-kms-tls-auth is an optional utility for s2n-tls that enables customers to use AWS KMS keys as part of the PSK extension field in a TLS 1.3 handshake. An issue exists in this library that can lead to overallocation of memory potentially resulting in a denial of service.\n\n### Impact\nThe PSK extension field in TLS 1.3 uses length-prefixed lists to encode variable-length data. aws-kms-tls-auth interprets the length prefix incorrectly resulting in additional memory allocation. \n\ns2n-tls limits ClientHello messages to 64 KB. Due to this issue, the server may allocate up to 10× the received size, meaning a single message could trigger an allocation of up to 640 KB. Repeated allocations of this size could exhaust server resources and lead to a denial-of-service.\n\nNo AWS services are affected. Applications should continue to follow best practices by limiting the number of in-flight handshakes and concurrent connections. Applications using the aws-kms-tls-auth crate should upgrade to version 0.0.3.\n\n**Impacted versions:** \u003c 0.0.3\n\n### Patches\nThis issue has been addressed in aws-kms-tls-auth v0.0.3 [1].\n\n### Workarounds\nThere is no workaround. Applications using aws-kms-tls-auth should upgrade to the most recent release.\n\n### Acknowledgement \ns2n-tls would like to thank Joshua Rogers (https://joshua.hu/) of AISLE Research Team (https://aisle.com/) for collaborating on this issue through the coordinated disclosure process.\n\nIf there are any questions or comments about this advisory, contact AWS/Amazon Security via the vulnerability reporting page [2] or directly via email to [aws-security@amazon.com](mailto:aws-security@amazon.com). Please do not create a public GitHub issue.\n\n[1] https://crates.io/crates/aws-kms-tls-auth/0.0.3\n[2] Vulnerability reporting page: https://aws.amazon.com/security/vulnerability-reporting","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"aws-kms-tls-auth vulnerable to memory overallocation","id":"GHSA-5whh-4q9j-7v28","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["0.0.3"],"introduced":["0"],"last_affected":[],"package":"aws-kms-tls-auth","purl":null,"source":"GHSA-5whh-4q9j-7v28"},{"ecosystem":"crates.io","fixed":["0.0.3"],"introduced":["0"],"last_affected":[],"package":"aws-kms-tls-auth","purl":"pkg:cargo/aws-kms-tls-auth","source":"GHSA-5whh-4q9j-7v28"}],"products":null,"published":"2026-03-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A memory overallocation flaw in aws-kms-tls-auth allows remote attackers to cause denial of service via crafted TLS handshakes.","url":"https://insights.sbomify.com/GHSA-5whh-4q9j-7v28/"}