{"answers":{"affected":"2 open source packages ship an affected version, including passport-wsfed-saml2.","exploited":"There is no known exploitation of GHSA-5wrg-8fxp-cx9r in the wild and no public exploit code.","fix":"Upgrade passport-wsfed-saml2 to 3.0.10 or later.","what":"GHSA-5wrg-8fxp-cx9r is a vulnerability in passport-wsfed-saml2, published on 21 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-5wrg-8fxp-cx9r and fix it if it is affected.\n\nWhat it is: GHSA-5wrg-8fxp-cx9r is a vulnerability in passport-wsfed-saml2, published on 21 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-5wrg-8fxp-cx9r in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- passport-wsfed-saml2 (npm): affected all versions; fixed in 3.0.10\n- passport-wsfed-saml2 (npm): affected all versions; fixed in 3.0.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-5wrg-8fxp-cx9r/ (Markdown: https://insights.sbomify.com/GHSA-5wrg-8fxp-cx9r/index.md)","id":"GHSA-5wrg-8fxp-cx9r","markdown":"https://insights.sbomify.com/GHSA-5wrg-8fxp-cx9r/index.md","name":"GHSA-5wrg-8fxp-cx9r","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js SAML library","requires_auth":"low_privilege","summary":"An authenticated attacker can bypass SAML signature validation to modify assertion fields, potentially escalating privileges or altering user data.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Information\nPlease note that this is not a new disclosure, and is previously reported in our [SECURITY-NOTICE.md](https://github.com/auth0/passport-wsfed-saml2/commit/520b9fc0bb4249ce83bec47e30153419f086ab70\n) which we removed in favor of github advisory. \n\n# Overview\n\nA vulnerability was found in the validation of a SAML signature. The validation doesn't ensure that the \"Signature\" tag is at the proper location inside an \"Assertion\" tag. This leads to a signature relocation attack where the attacker can corrupt one field of data while maintaining the signature valid. This could allow an authenticated attacker to \"remove\" one group from the assertion or corrupt another field of an assertion.\n\n# Am I affected?\n\nYou are affected if you are using the passport-wsfed-saml2 library to version \u003c 3.0.10\n\n# How do I fix it?\n\nYou may fix this issue by upgrading passport-wsfed-saml2 library to version 3.0.10 or above. \n\n# Will the fix impact my users?\n\nThis fix patches the library that your application runs, but will not impact your users, their current state, or any existing sessions.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"passport-wsfed-saml2 Signature Bypass vulnerability","id":"GHSA-5wrg-8fxp-cx9r","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["3.0.10"],"introduced":["0"],"last_affected":[],"package":"passport-wsfed-saml2","purl":null,"source":"GHSA-5wrg-8fxp-cx9r"},{"ecosystem":"npm","fixed":["3.0.10"],"introduced":["0"],"last_affected":[],"package":"passport-wsfed-saml2","purl":"pkg:npm/passport-wsfed-saml2","source":"GHSA-5wrg-8fxp-cx9r"}],"products":null,"published":"2023-06-21","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An authenticated attacker can bypass SAML signature validation to modify assertion fields, potentially escalating privileges or altering user data.","url":"https://insights.sbomify.com/GHSA-5wrg-8fxp-cx9r/"}