GHSA-5x28-3f32-x523 Drupal core Access control bypass
Drupal core allows unauthorized access to media items when the advanced UI is enabled, requiring an upgrade or configuration change.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-5x28-3f32-x523?
GHSA-5x28-3f32-x523 is a missing authorization vulnerability in drupal/drupal, published on 15 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The Media Library module has a security vulnerability whereby it doesn't sufficiently restrict access to media items in certain configurations.
Solution:
If you are using Drupal 8.7.x, you should upgrade to Drupal 8.7.11. If you are using Drupal 8.8.x, you should upgrade to Drupal 8.8.1. Versions of Drupal 8 prior to 8.7.x are end-of-life and do not receive security coverage.
Alternatively, you may mitigate this vulnerability by unchecking the "Enable advanced UI" checkbox on /admin/config/media/media-library. (This mitigation is not available in 8.7.x.)
Which versions are affected by GHSA-5x28-3f32-x523?
4 open source packages ship an affected version, including drupal/drupal.
| Package | Affected | Fixed in |
|---|---|---|
drupal/drupal Packagist | From 8.0.0 | 8.7.11 |
drupal/drupal Packagist | From 8.0.0 | 8.7.11 |
drupal/drupal Packagist | From 8.8.0 | 8.8.1 |
drupal/drupal Packagist | From 8.8.0 | 8.8.1 |
How do I fix GHSA-5x28-3f32-x523?
Upgrade drupal/drupal to a fixed version for your release line: 8.7.11 or 8.8.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is GHSA-5x28-3f32-x523 being exploited?
There is no known exploitation of GHSA-5x28-3f32-x523 in the wild and no public exploit code.