# GHSA-5x28-3f32-x523: Drupal core Access control bypass

> Drupal core allows unauthorized access to media items when the advanced UI is enabled, requiring an upgrade or configuration change.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 May 2024

## What is GHSA-5x28-3f32-x523?

GHSA-5x28-3f32-x523 is a missing authorization vulnerability in drupal/drupal, published on 15 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Media Library module has a security vulnerability whereby it doesn't sufficiently restrict access to media items in certain configurations.

### Solution: 
If you are using Drupal 8.7.x, you should upgrade to Drupal 8.7.11.
If you are using Drupal 8.8.x, you should upgrade to Drupal 8.8.1.
Versions of Drupal 8 prior to 8.7.x are end-of-life and do not receive security coverage.

Alternatively, you may mitigate this vulnerability by unchecking the "Enable advanced UI" checkbox on `/admin/config/media/media-library`. (This mitigation is not available in 8.7.x.)

## Which versions are affected by GHSA-5x28-3f32-x523?

4 open source packages ship an affected version, including drupal/drupal.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/drupal` | Packagist | From 8.0.0 | 8.7.11 |
| `drupal/drupal` | Packagist | From 8.0.0 | 8.7.11 |
| `drupal/drupal` | Packagist | From 8.8.0 | 8.8.1 |
| `drupal/drupal` | Packagist | From 8.8.0 | 8.8.1 |

## How do I fix GHSA-5x28-3f32-x523?

Upgrade drupal/drupal to a fixed version for your release line: 8.7.11 or 8.8.1.

## Is GHSA-5x28-3f32-x523 being exploited?

There is no known exploitation of GHSA-5x28-3f32-x523 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-5x28-3f32-x523 and fix it if it is affected.

What it is: GHSA-5x28-3f32-x523 is a missing authorization vulnerability in drupal/drupal, published on 15 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-5x28-3f32-x523 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/drupal (Packagist): affected from 8.0.0; fixed in 8.7.11
- drupal/drupal (Packagist): affected from 8.0.0; fixed in 8.7.11
- drupal/drupal (Packagist): affected from 8.8.0; fixed in 8.8.1
- drupal/drupal (Packagist): affected from 8.8.0; fixed in 8.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-5x28-3f32-x523/ (Markdown: https://insights.sbomify.com/GHSA-5x28-3f32-x523/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-5x28-3f32-x523

---
From sbomify Insights: https://insights.sbomify.com/GHSA-5x28-3f32-x523/
Summaries are generated and may contain mistakes; the official description above is the record.
