{"answers":{"affected":"2 open source packages ship an affected version, including com.intuit.karate:karate-core.","exploited":"There is no known exploitation of GHSA-5x5q-8cgm-2hjq in the wild and no public exploit code.","fix":"Upgrade com.intuit.karate:karate-core to 1.4.0 or later.","what":"GHSA-5x5q-8cgm-2hjq is a vulnerability in com.intuit.karate:karate-core, published on 31 Mar 2023."},"fix_prompt":"Check this codebase for GHSA-5x5q-8cgm-2hjq and fix it if it is affected.\n\nWhat it is: GHSA-5x5q-8cgm-2hjq is a vulnerability in com.intuit.karate:karate-core, published on 31 Mar 2023. \nExploitation: There is no known exploitation of GHSA-5x5q-8cgm-2hjq in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.intuit.karate:karate-core (Maven): affected from 1.3.1; fixed in 1.4.0\n- com.intuit.karate:karate-core (Maven): affected from 1.3.1; fixed in 1.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-5x5q-8cgm-2hjq/ (Markdown: https://insights.sbomify.com/GHSA-5x5q-8cgm-2hjq/index.md)","id":"GHSA-5x5q-8cgm-2hjq","markdown":"https://insights.sbomify.com/GHSA-5x5q-8cgm-2hjq/index.md","name":"GHSA-5x5q-8cgm-2hjq","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"unknown","non_default_config":false,"product_category":"Karate testing library","requires_auth":"unknown","summary":"Karate includes a vulnerable json-smart dependency allowing code execution; users should upgrade the json-path dependency.","user_interaction":"unknown","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Summary\nThe CVE \n![image](https://user-images.githubusercontent.com/2663049/229081854-1155c041-56fa-48ca-a7ff-f2f085b845fd.png)\n\n### How to fix it\nVery simple, just upgrade json-path package to 2.8.0 (from 2.7.0) inside karate-core pom.xml ;)","ecosystems":["Maven"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Karate has vulnerable dependency on json-smart package (CVE-2023-1370)","id":"GHSA-5x5q-8cgm-2hjq","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Maven","product":null,"products":[],"type":"supply_chain","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Maven","fixed":["1.4.0"],"introduced":["1.3.1"],"last_affected":[],"package":"com.intuit.karate:karate-core","purl":null,"source":"GHSA-5x5q-8cgm-2hjq"},{"ecosystem":"Maven","fixed":["1.4.0"],"introduced":["1.3.1"],"last_affected":[],"package":"com.intuit.karate:karate-core","purl":"pkg:maven/com.intuit.karate/karate-core","source":"GHSA-5x5q-8cgm-2hjq"}],"products":null,"published":"2023-03-31","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Karate includes a vulnerable json-smart dependency allowing code execution; users should upgrade the json-path dependency.","url":"https://insights.sbomify.com/GHSA-5x5q-8cgm-2hjq/"}