GHSA-635v-pc42-fr74 AWS SageMaker Training Toolkit logs CodeArtifact Authorization token
Attackers with CloudWatch log access can steal CodeArtifact tokens to publish or consume packages if logging is enabled.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-635v-pc42-fr74?
GHSA-635v-pc42-fr74 is a vulnerability in sagemaker-training, published on 11 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Description
For SageMaker Training Toolkit[1] versions 4.7.4; 4.7.3; 4.7.2; 4.7.1; 4.7.0, the authorization tokens for CodeArtifact (temporary token with an expiration of 12 hours) were logged in the log files when the CodeArtifact capability was enabled. If customers push these log files to their CloudWatch Log streams, anyone having access to cloudwatch logs within their AWS account, may be abe to see the authorization token. If the token is not expired, they may use the authorization token to publish or consume CodeArtifact package versions.
This issue was addressed in version 4.8.0. We recommend users upgrade to version 4.8.0 or higher.
Please note that users can add SageMaker Training Toolkit to any Docker container[2] used for SageMaker training[3]. It also comes pre-packaged with the prebuilt SageMaker Docker image[4] for SageMaker training.
Patches
This issue has been addressed in version 4.8.0 and higher.
Workarounds
N/A
References
N/A
If you have any questions or comments about this advisory we ask that you contact AWS/Amazon Security via our vulnerability reporting page[5] or directly via email to [email protected]. Please do not create a public GitHub issue.
[1] https://github.com/aws/sagemaker-training-toolkit [2] https://www.docker.com/resources/what-container/ [3] https://aws.amazon.com/sagemaker/train/ [4] https://docs.aws.amazon.com/sagemaker/latest/dg/pre-built-containers-frameworks-deep-learning.html [5] Vulnerability reporting page: https://aws.amazon.com/security/vulnerability-reporting
Which versions are affected by GHSA-635v-pc42-fr74?
2 open source packages ship an affected version, including sagemaker-training.
| Package | Affected | Fixed in |
|---|---|---|
sagemaker-training PyPI | From 4.7.0 | 4.8.0 |
sagemaker-training PyPI | From 4.7.0 | 4.8.0 |
How do I fix GHSA-635v-pc42-fr74?
Upgrade sagemaker-training to 4.8.0 or later.
Is GHSA-635v-pc42-fr74 being exploited?
There is no known exploitation of GHSA-635v-pc42-fr74 in the wild and no public exploit code.