{"answers":{"affected":"2 open source packages ship an affected version, including commonmarker.","exploited":"There is no known exploitation of GHSA-636f-xm5j-pj9m in the wild and no public exploit code.","fix":"Upgrade commonmarker to 0.23.7 or later.","what":"GHSA-636f-xm5j-pj9m is a denial of service vulnerability in commonmarker, published on 24 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-636f-xm5j-pj9m and fix it if it is affected.\n\nWhat it is: GHSA-636f-xm5j-pj9m is a denial of service vulnerability in commonmarker, published on 24 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-636f-xm5j-pj9m in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- commonmarker (RubyGems): affected all versions; fixed in 0.23.7\n- commonmarker (RubyGems): affected all versions; fixed in 0.23.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-636f-xm5j-pj9m/ (Markdown: https://insights.sbomify.com/GHSA-636f-xm5j-pj9m/index.md)","id":"GHSA-636f-xm5j-pj9m","markdown":"https://insights.sbomify.com/GHSA-636f-xm5j-pj9m/index.md","name":"GHSA-636f-xm5j-pj9m","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby Markdown library","requires_auth":"none","summary":"Quadratic complexity bugs in the Commonmarker library allow attackers to cause denial of service via resource exhaustion.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Impact\n\nSeveral quadratic complexity bugs in commonmarker's underlying [`cmark-gfm`](https://github.com/github/cmark-gfm) library may lead to unbounded resource exhaustion and subsequent denial of service.\n\nThe following vulnerabilities were addressed:\n\n* [CVE-2023-22483](https://github.com/github/cmark-gfm/security/advisories/GHSA-29g3-96g3-jg6c)\n* [CVE-2023-22484](https://github.com/github/cmark-gfm/security/advisories/GHSA-24f7-9frr-5h2r)\n* [CVE-2023-22485](https://github.com/github/cmark-gfm/security/advisories/GHSA-c944-cv5f-hpvr)\n* [CVE-2023-22486](https://github.com/github/cmark-gfm/security/advisories/GHSA-r572-jvj2-3m8p)\n\nFor more information, consult the release notes for version [`0.23.0.gfm.7`](https://github.com/github/cmark-gfm/releases/tag/0.29.0.gfm.7).\n\n## Mitigation\n\nUsers are advised to upgrade to commonmarker version [`0.23.7`](https://rubygems.org/gems/commonmarker/versions/0.23.7).","ecosystems":["RubyGems"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Several quadratic complexity bugs may lead to denial of service in Commonmarker","id":"GHSA-636f-xm5j-pj9m","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"RubyGems","fixed":["0.23.7"],"introduced":["0"],"last_affected":[],"package":"commonmarker","purl":null,"source":"GHSA-636f-xm5j-pj9m"},{"ecosystem":"RubyGems","fixed":["0.23.7"],"introduced":["0"],"last_affected":[],"package":"commonmarker","purl":"pkg:gem/commonmarker","source":"GHSA-636f-xm5j-pj9m"}],"products":null,"published":"2023-01-24","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Quadratic complexity bugs in the Commonmarker library allow attackers to cause denial of service via resource exhaustion.","url":"https://insights.sbomify.com/GHSA-636f-xm5j-pj9m/"}