{"answers":{"affected":"2 open source packages ship an affected version, including nwmatcher.","exploited":"There is no known exploitation of GHSA-6394-6h9h-cfjg in the wild and no public exploit code.","fix":"Upgrade nwmatcher to 1.4.4 or later.","what":"GHSA-6394-6h9h-cfjg is a denial of service vulnerability in nwmatcher, published on 7 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-6394-6h9h-cfjg and fix it if it is affected.\n\nWhat it is: GHSA-6394-6h9h-cfjg is a denial of service vulnerability in nwmatcher, published on 7 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-6394-6h9h-cfjg in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nwmatcher (npm): affected all versions; fixed in 1.4.4\n- nwmatcher (npm): affected all versions; fixed in 1.4.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-6394-6h9h-cfjg/ (Markdown: https://insights.sbomify.com/GHSA-6394-6h9h-cfjg/index.md)","id":"GHSA-6394-6h9h-cfjg","markdown":"https://insights.sbomify.com/GHSA-6394-6h9h-cfjg/index.md","name":"GHSA-6394-6h9h-cfjg","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"npm regex library","requires_auth":"none","summary":"An attacker can cause a denial of service in applications using the nwmatcher library by triggering a regular expression vulnerability.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"A Regular Expression vulnerability was found in nwmatcher before 1.4.4. The fix replacing multiple repeated instances of the \"\\s*\" pattern.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Regular Expression Denial of Service","id":"GHSA-6394-6h9h-cfjg","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.4.4"],"introduced":["0"],"last_affected":[],"package":"nwmatcher","purl":null,"source":"GHSA-6394-6h9h-cfjg"},{"ecosystem":"npm","fixed":["1.4.4"],"introduced":["0"],"last_affected":[],"package":"nwmatcher","purl":"pkg:npm/nwmatcher","source":"GHSA-6394-6h9h-cfjg"}],"products":null,"published":"2019-06-07","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can cause a denial of service in applications using the nwmatcher library by triggering a regular expression vulnerability.","url":"https://insights.sbomify.com/GHSA-6394-6h9h-cfjg/"}