GHSA-63cx-g855-hvv4 mitmproxy binaries embed a vulnerable python-hyper/h2 dependency
Attackers can perform HTTP request smuggling when mitmproxy translates HTTP/2 to HTTP/1, potentially compromising data integrity and confidentiality.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-63cx-g855-hvv4?
GHSA-63cx-g855-hvv4 is a vulnerability in mitmproxy, published on 25 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
mitmproxy 12.1.1 and below embed python-hyper/h2 ≤ v4.2.0, which has a gap in its HTTP/2 header validation. This enables request smuggling attacks when mitmproxy is in a configuration where it translates HTTP/2 to HTTP/1. For example, this affects reverse proxies to http:// backends. It does not affect mitmproxy's regular mode.
All users are encouraged to upgrade to mitmproxy 12.1.2, which includes a fixed version of h2.
More details about the vulnerability itself can be found at https://github.com/python-hyper/h2/security/advisories/GHSA-847f-9342-265h.
Which versions are affected by GHSA-63cx-g855-hvv4?
2 open source packages ship an affected version, including mitmproxy.
| Package | Affected | Fixed in |
|---|---|---|
mitmproxy PyPI | All versions | 12.1.2 |
mitmproxy PyPI | All versions | 12.1.2 |
How do I fix GHSA-63cx-g855-hvv4?
Upgrade mitmproxy to 12.1.2 or later.
Is GHSA-63cx-g855-hvv4 being exploited?
There is no known exploitation of GHSA-63cx-g855-hvv4 in the wild and no public exploit code.