{"answers":{"affected":"2 open source packages ship an affected version, including mitmproxy.","exploited":"There is no known exploitation of GHSA-63cx-g855-hvv4 in the wild and no public exploit code.","fix":"Upgrade mitmproxy to 12.1.2 or later.","what":"GHSA-63cx-g855-hvv4 is a vulnerability in mitmproxy, published on 25 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-63cx-g855-hvv4 and fix it if it is affected.\n\nWhat it is: GHSA-63cx-g855-hvv4 is a vulnerability in mitmproxy, published on 25 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-63cx-g855-hvv4 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mitmproxy (PyPI): affected all versions; fixed in 12.1.2\n- mitmproxy (PyPI): affected all versions; fixed in 12.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-63cx-g855-hvv4/ (Markdown: https://insights.sbomify.com/GHSA-63cx-g855-hvv4/index.md)","id":"GHSA-63cx-g855-hvv4","markdown":"https://insights.sbomify.com/GHSA-63cx-g855-hvv4/index.md","name":"GHSA-63cx-g855-hvv4","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"mitmproxy HTTP proxy","requires_auth":"none","summary":"Attackers can perform HTTP request smuggling when mitmproxy translates HTTP/2 to HTTP/1, potentially compromising data integrity and confidentiality.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"mitmproxy 12.1.1 and below embed python-hyper/h2 ≤ v4.2.0, which has a gap in its HTTP/2 header validation. This enables request smuggling attacks when mitmproxy is in a configuration where it translates HTTP/2 to HTTP/1. For example, this affects reverse proxies to `http://` backends. It does not affect mitmproxy's regular mode.\n\nAll users are encouraged to upgrade to mitmproxy 12.1.2, which includes a fixed version of h2.\n\nMore details about the vulnerability itself can be found at https://github.com/python-hyper/h2/security/advisories/GHSA-847f-9342-265h.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"mitmproxy binaries embed a vulnerable python-hyper/h2 dependency","id":"GHSA-63cx-g855-hvv4","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"other","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["12.1.2"],"introduced":["0"],"last_affected":[],"package":"mitmproxy","purl":null,"source":"GHSA-63cx-g855-hvv4"},{"ecosystem":"PyPI","fixed":["12.1.2"],"introduced":["0"],"last_affected":[],"package":"mitmproxy","purl":"pkg:pypi/mitmproxy","source":"GHSA-63cx-g855-hvv4"}],"products":null,"published":"2025-08-25","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can perform HTTP request smuggling when mitmproxy translates HTTP/2 to HTTP/1, potentially compromising data integrity and confidentiality.","url":"https://insights.sbomify.com/GHSA-63cx-g855-hvv4/"}