# GHSA-63cx-g855-hvv4: mitmproxy binaries embed a vulnerable python-hyper/h2 dependency

> Attackers can perform HTTP request smuggling when mitmproxy translates HTTP/2 to HTTP/1, potentially compromising data integrity and confidentiality.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2025

## What is GHSA-63cx-g855-hvv4?

GHSA-63cx-g855-hvv4 is a vulnerability in mitmproxy, published on 25 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

mitmproxy 12.1.1 and below embed python-hyper/h2 ≤ v4.2.0, which has a gap in its HTTP/2 header validation. This enables request smuggling attacks when mitmproxy is in a configuration where it translates HTTP/2 to HTTP/1. For example, this affects reverse proxies to `http://` backends. It does not affect mitmproxy's regular mode.

All users are encouraged to upgrade to mitmproxy 12.1.2, which includes a fixed version of h2.

More details about the vulnerability itself can be found at https://github.com/python-hyper/h2/security/advisories/GHSA-847f-9342-265h.

## Which versions are affected by GHSA-63cx-g855-hvv4?

2 open source packages ship an affected version, including mitmproxy.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mitmproxy` | PyPI | All versions | 12.1.2 |
| `mitmproxy` | PyPI | All versions | 12.1.2 |

## How do I fix GHSA-63cx-g855-hvv4?

Upgrade mitmproxy to 12.1.2 or later.

## Is GHSA-63cx-g855-hvv4 being exploited?

There is no known exploitation of GHSA-63cx-g855-hvv4 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-63cx-g855-hvv4 and fix it if it is affected.

What it is: GHSA-63cx-g855-hvv4 is a vulnerability in mitmproxy, published on 25 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-63cx-g855-hvv4 in the wild and no public exploit code.

Affected packages and fixed versions:
- mitmproxy (PyPI): affected all versions; fixed in 12.1.2
- mitmproxy (PyPI): affected all versions; fixed in 12.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-63cx-g855-hvv4/ (Markdown: https://insights.sbomify.com/GHSA-63cx-g855-hvv4/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-63cx-g855-hvv4

---
From sbomify Insights: https://insights.sbomify.com/GHSA-63cx-g855-hvv4/
Summaries are generated and may contain mistakes; the official description above is the record.
