GHSA-6475-r3vj-m8vf AWS SDK for JavaScript v3 adopted defense in depth enhancement for region parameter value

Not scored Published

AWS SDK for JavaScript v3 added validation to prevent invalid region values from routing API calls to non-AWS hosts, requiring an upgrade for defense-in-depth.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is GHSA-6475-r3vj-m8vf?

GHSA-6475-r3vj-m8vf is a vulnerability in @smithy/config-resolver, published on 8 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

CVSSv3.1 Rating: 3.7 (LOW)

Summary

This notification is related to the use of specific values for the region input field when calling AWS services. An actor with access to the environment in which the SDK is used could set the region input field to an invalid value.

A defense-in-depth enhancement has been implemented in the AWS SDK for JavaScript v3 (versions 3.723.0 and later). This enhancement validates that a region used to construct an endpoint URL is a valid host label. The change was released on November 15, 2025. This advisory is informational to help customers understand their responsibilities regarding configuration security.

Impact Customer applications could be configured to improperly route AWS API calls to non-existent or non-AWS hosts. While the SDK was functioning as designed, additional safeguards have been added to support secure customer implementations.

Impacted versions: @smithy/config-resolver <4.4.0

Patches

On November 15, 2025, an enhancement was made to the AWS SDK for JavaScript v3 (versions 3.723.0 and later) release, which validates the formatting of a region, providing additional safeguards. A feature enhancement was implemented in @smithy/config-resolver v4.4.0. This enhancement provides additional configuration validation safeguards but does not address a security vulnerability.

Workarounds No workarounds are needed, but as always you should ensure that your application is following security best practices:

  • Implement proper input validation in your application code
  • Update to the latest AWS SDK for Javascript v3 release on a regular basis
  • Follow AWS security best practices [1] for SDK configuration

Resources Contact AWS Security via the vulnerability reporting page or email [email protected].

Acknowledgement AWS Security thanks Guy Arazi for bringing these customer security considerations to our attention through the coordinated disclosure process.

[1] https://docs.aws.amazon.com/sdk-for-javascript/v3/developer-guide/security.html

Which versions are affected by GHSA-6475-r3vj-m8vf?

2 open source packages ship an affected version, including @smithy/config-resolver.

PackageAffectedFixed in
@smithy/config-resolver npmAll versions4.4.0
@smithy/config-resolver npmAll versions4.4.0

How do I fix GHSA-6475-r3vj-m8vf?

Upgrade @smithy/config-resolver to 4.4.0 or later.

Is GHSA-6475-r3vj-m8vf being exploited?

There is no known exploitation of GHSA-6475-r3vj-m8vf in the wild and no public exploit code.

Sources

Is GHSA-6475-r3vj-m8vf in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free