{"answers":{"affected":"2 open source packages ship an affected version, including @smithy/config-resolver.","exploited":"There is no known exploitation of GHSA-6475-r3vj-m8vf in the wild and no public exploit code.","fix":"Upgrade @smithy/config-resolver to 4.4.0 or later.","what":"GHSA-6475-r3vj-m8vf is a vulnerability in @smithy/config-resolver, published on 8 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-6475-r3vj-m8vf and fix it if it is affected.\n\nWhat it is: GHSA-6475-r3vj-m8vf is a vulnerability in @smithy/config-resolver, published on 8 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-6475-r3vj-m8vf in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @smithy/config-resolver (npm): affected all versions; fixed in 4.4.0\n- @smithy/config-resolver (npm): affected all versions; fixed in 4.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-6475-r3vj-m8vf/ (Markdown: https://insights.sbomify.com/GHSA-6475-r3vj-m8vf/index.md)","id":"GHSA-6475-r3vj-m8vf","markdown":"https://insights.sbomify.com/GHSA-6475-r3vj-m8vf/index.md","name":"GHSA-6475-r3vj-m8vf","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":true,"product_category":"AWS SDK JavaScript","requires_auth":"none","summary":"AWS SDK for JavaScript v3 added validation to prevent invalid region values from routing API calls to non-AWS hosts, requiring an upgrade for defense-in-depth.","user_interaction":"not_required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"CVSSv3.1 Rating: 3.7 (LOW)\n\nSummary\n\nThis notification is related to the use of specific values for the region input field when calling AWS services. An actor with access to the environment in which the SDK is used could set the region input field to an invalid value.\n\nA defense-in-depth enhancement has been implemented in the AWS SDK for JavaScript v3 (versions 3.723.0 and later). This enhancement validates that a region used to construct an endpoint URL is a valid host label. The change was released on November 15, 2025. This advisory is informational to help customers understand their responsibilities regarding configuration security.\n\nImpact\nCustomer applications could be configured to improperly route AWS API calls to non-existent or non-AWS hosts. While the SDK was functioning as designed, additional safeguards have been added to support secure customer implementations.\n\nImpacted versions: @smithy/config-resolver \u003c4.4.0\n\nPatches\n\nOn November 15, 2025, an enhancement was made to the AWS SDK for JavaScript v3 (versions 3.723.0 and later) release, which validates the formatting of a region, providing additional safeguards. A feature enhancement was implemented in @smithy/config-resolver v4.4.0. This enhancement provides additional configuration validation safeguards but does not address a security vulnerability.\n\nWorkarounds\nNo workarounds are needed, but as always you should ensure that your application is following security best practices:\n- Implement proper input validation in your application code\n- Update to the latest AWS SDK for Javascript v3 release on a regular basis\n- Follow AWS security best practices [1] for SDK configuration\n\nResources\nContact AWS Security via the vulnerability reporting page or email [aws-security@amazon.com](mailto:aws-security@amazon.com).\n\nAcknowledgement\nAWS Security thanks Guy Arazi for bringing these customer security considerations to our attention through the coordinated disclosure process.\n\n[1] https://docs.aws.amazon.com/sdk-for-javascript/v3/developer-guide/security.html","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"AWS SDK for JavaScript v3 adopted defense in depth enhancement for region parameter value","id":"GHSA-6475-r3vj-m8vf","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"misconfiguration","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["4.4.0"],"introduced":["0"],"last_affected":[],"package":"@smithy/config-resolver","purl":null,"source":"GHSA-6475-r3vj-m8vf"},{"ecosystem":"npm","fixed":["4.4.0"],"introduced":["0"],"last_affected":[],"package":"@smithy/config-resolver","purl":"pkg:npm/%40smithy/config-resolver","source":"GHSA-6475-r3vj-m8vf"}],"products":null,"published":"2026-01-08","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"AWS SDK for JavaScript v3 added validation to prevent invalid region values from routing API calls to non-AWS hosts, requiring an upgrade for defense-in-depth.","url":"https://insights.sbomify.com/GHSA-6475-r3vj-m8vf/"}