# GHSA-6475-r3vj-m8vf: AWS SDK for JavaScript v3 adopted defense in depth enhancement for region parameter value

> AWS SDK for JavaScript v3 added validation to prevent invalid region values from routing API calls to non-AWS hosts, requiring an upgrade for defense-in-depth.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2026

## What is GHSA-6475-r3vj-m8vf?

GHSA-6475-r3vj-m8vf is a vulnerability in @smithy/config-resolver, published on 8 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CVSSv3.1 Rating: 3.7 (LOW)

Summary

This notification is related to the use of specific values for the region input field when calling AWS services. An actor with access to the environment in which the SDK is used could set the region input field to an invalid value.

A defense-in-depth enhancement has been implemented in the AWS SDK for JavaScript v3 (versions 3.723.0 and later). This enhancement validates that a region used to construct an endpoint URL is a valid host label. The change was released on November 15, 2025. This advisory is informational to help customers understand their responsibilities regarding configuration security.

Impact
Customer applications could be configured to improperly route AWS API calls to non-existent or non-AWS hosts. While the SDK was functioning as designed, additional safeguards have been added to support secure customer implementations.

Impacted versions: @smithy/config-resolver <4.4.0

Patches

On November 15, 2025, an enhancement was made to the AWS SDK for JavaScript v3 (versions 3.723.0 and later) release, which validates the formatting of a region, providing additional safeguards. A feature enhancement was implemented in @smithy/config-resolver v4.4.0. This enhancement provides additional configuration validation safeguards but does not address a security vulnerability.

Workarounds
No workarounds are needed, but as always you should ensure that your application is following security best practices:
- Implement proper input validation in your application code
- Update to the latest AWS SDK for Javascript v3 release on a regular basis
- Follow AWS security best practices [1] for SDK configuration

Resources
Contact AWS Security via the vulnerability reporting page or email [aws-security@amazon.com](mailto:aws-security@amazon.com).

Acknowledgement
AWS Security thanks Guy Arazi for bringing these customer security considerations to our attention through the coordinated disclosure process.

[1] https://docs.aws.amazon.com/sdk-for-javascript/v3/developer-guide/security.html

## Which versions are affected by GHSA-6475-r3vj-m8vf?

2 open source packages ship an affected version, including @smithy/config-resolver.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@smithy/config-resolver` | npm | All versions | 4.4.0 |
| `@smithy/config-resolver` | npm | All versions | 4.4.0 |

## How do I fix GHSA-6475-r3vj-m8vf?

Upgrade @smithy/config-resolver to 4.4.0 or later.

## Is GHSA-6475-r3vj-m8vf being exploited?

There is no known exploitation of GHSA-6475-r3vj-m8vf in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-6475-r3vj-m8vf and fix it if it is affected.

What it is: GHSA-6475-r3vj-m8vf is a vulnerability in @smithy/config-resolver, published on 8 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-6475-r3vj-m8vf in the wild and no public exploit code.

Affected packages and fixed versions:
- @smithy/config-resolver (npm): affected all versions; fixed in 4.4.0
- @smithy/config-resolver (npm): affected all versions; fixed in 4.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-6475-r3vj-m8vf/ (Markdown: https://insights.sbomify.com/GHSA-6475-r3vj-m8vf/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-6475-r3vj-m8vf

---
From sbomify Insights: https://insights.sbomify.com/GHSA-6475-r3vj-m8vf/
Summaries are generated and may contain mistakes; the official description above is the record.
