{"answers":{"affected":"2 open source packages ship an affected version, including org.jboss.hal:hal-console.","exploited":"There is no known exploitation of GHSA-64gp-r758-8pfm in the wild and no public exploit code.","fix":"Upgrade org.jboss.hal:hal-console to 3.7.7.Final or later.","what":"GHSA-64gp-r758-8pfm is a cross-site scripting vulnerability in org.jboss.hal:hal-console, published on 23 Dec 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-64gp-r758-8pfm and fix it if it is affected.\n\nWhat it is: GHSA-64gp-r758-8pfm is a cross-site scripting vulnerability in org.jboss.hal:hal-console, published on 23 Dec 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-64gp-r758-8pfm in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jboss.hal:hal-console (Maven): affected all versions; fixed in 3.7.7.Final\n- org.jboss.hal:hal-console (Maven): affected all versions; fixed in 3.7.7.Final\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-64gp-r758-8pfm/ (Markdown: https://insights.sbomify.com/GHSA-64gp-r758-8pfm/index.md)","id":"GHSA-64gp-r758-8pfm","markdown":"https://insights.sbomify.com/GHSA-64gp-r758-8pfm/index.md","name":"GHSA-64gp-r758-8pfm","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"WildFly management console","requires_auth":"high_privilege","summary":"An attacker with high privileges can execute malicious scripts in the WildFly management console during content upload, potentially compromising the server.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"A vulnerability was found in the WildFly management console. A user may perform cross-site scripting in the deployment system. An attacker (or insider) may execute a malicious payload which could trigger an undesired behavior against the server.\n\n### Impact\nCross-site scripting (XSS) vulnerability in the management console.\n\n### Patches\nFixed in [HAL 3.7.7.Final](https://github.com/hal/console/releases/tag/v3.7.7) \n\n### Workarounds\nNo workaround available\n\n### References\nSee also: https://issues.redhat.com/browse/WFLY-19969","ecosystems":["Maven"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross Site Scripting (XSS) vulnerability while uploading content to a new deployment","id":"GHSA-64gp-r758-8pfm","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Maven","fixed":["3.7.7.Final"],"introduced":["0"],"last_affected":[],"package":"org.jboss.hal:hal-console","purl":null,"source":"GHSA-64gp-r758-8pfm"},{"ecosystem":"Maven","fixed":["3.7.7.Final"],"introduced":["0"],"last_affected":[],"package":"org.jboss.hal:hal-console","purl":"pkg:maven/org.jboss.hal/hal-console","source":"GHSA-64gp-r758-8pfm"}],"products":null,"published":"2024-12-23","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker with high privileges can execute malicious scripts in the WildFly management console during content upload, potentially compromising the server.","url":"https://insights.sbomify.com/GHSA-64gp-r758-8pfm/"}