{"answers":{"affected":"2 open source packages ship an affected version, including brotkrueml/codehighlight.","exploited":"There is no known exploitation of GHSA-65xh-hh78-6454 in the wild and no public exploit code.","fix":"Upgrade brotkrueml/codehighlight to 2.7.0 or later.","what":"GHSA-65xh-hh78-6454 is a denial of service vulnerability in brotkrueml/codehighlight, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-65xh-hh78-6454 and fix it if it is affected.\n\nWhat it is: GHSA-65xh-hh78-6454 is a denial of service vulnerability in brotkrueml/codehighlight, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-65xh-hh78-6454 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- brotkrueml/codehighlight (Packagist): affected all versions; fixed in 2.7.0\n- brotkrueml/codehighlight (Packagist): affected all versions; fixed in 2.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-65xh-hh78-6454/ (Markdown: https://insights.sbomify.com/GHSA-65xh-hh78-6454/index.md)","id":"GHSA-65xh-hh78-6454","markdown":"https://insights.sbomify.com/GHSA-65xh-hh78-6454/index.md","name":"GHSA-65xh-hh78-6454","record":{"aliases":[],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Code Highlight extension","requires_auth":"none","summary":"A vulnerable bundled library in the Code Highlight extension allows attackers to cause a denial of service via ReDoS.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"The codehighlight extension bundles a vulnerable version of the 3rd party JavaScript component “prism” which is known to be vulnerable against Regular expression Denial of Service (ReDoS).","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Denial of Service in extension \"Code Highlight\" (codehighlight)","id":"GHSA-65xh-hh78-6454","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["2.7.0"],"introduced":["0"],"last_affected":[],"package":"brotkrueml/codehighlight","purl":null,"source":"GHSA-65xh-hh78-6454"},{"ecosystem":"Packagist","fixed":["2.7.0"],"introduced":["0"],"last_affected":[],"package":"brotkrueml/codehighlight","purl":"pkg:composer/brotkrueml/codehighlight","source":"GHSA-65xh-hh78-6454"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A vulnerable bundled library in the Code Highlight extension allows attackers to cause a denial of service via ReDoS.","url":"https://insights.sbomify.com/GHSA-65xh-hh78-6454/"}