{"answers":{"affected":"3 open source packages ship an affected version, including xmp_toolkit.","exploited":"There is no known exploitation of GHSA-66fw-43h8-f8p3 in the wild and no public exploit code.","fix":"Upgrade xmp_toolkit to 1.9.0 or later.","what":"GHSA-66fw-43h8-f8p3 is a denial of service vulnerability in xmp_toolkit, published on 26 Jul 2024."},"fix_prompt":"Check this codebase for GHSA-66fw-43h8-f8p3 and fix it if it is affected.\n\nWhat it is: GHSA-66fw-43h8-f8p3 is a denial of service vulnerability in xmp_toolkit, published on 26 Jul 2024. \nExploitation: There is no known exploitation of GHSA-66fw-43h8-f8p3 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- xmp_toolkit (crates.io): affected all versions; fixed in 1.9.0\n- xmp_toolkit (crates.io): affected all versions; fixed in 1.9.0\n- xmp_toolkit (crates.io): affected from 0.0.0-0; fixed in 1.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-66fw-43h8-f8p3/ (Markdown: https://insights.sbomify.com/GHSA-66fw-43h8-f8p3/index.md)","id":"GHSA-66fw-43h8-f8p3","markdown":"https://insights.sbomify.com/GHSA-66fw-43h8-f8p3/index.md","name":"GHSA-66fw-43h8-f8p3","record":{"aliases":["RUSTSEC-2024-0360"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"unknown","non_default_config":false,"product_category":"Rust XMP library","requires_auth":"none","summary":"An attacker can cause a process abort via undefined behavior in XmpFile::close, requiring an upgrade to the Rust xmp_toolkit library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Affected versions of the crate failed to catch C++ exceptions raised within the `XmpFile::close` function. If such an exception occurred, it would trigger undefined behavior, typically a process abort.\n\nThis is best demonstrated in [issue #230](https://github.com/adobe/xmp-toolkit-rs/issues/230), where a race condition causes the `close` call to fail due to file I/O errors.\n\nThis was fixed in [PR #232](https://github.com/adobe/xmp-toolkit-rs/pull/232) (released as crate version 1.9.0), which now safely handles the exception.\n\nFor backward compatibility, the existing API ignores the error. A new API `XmpFile::try_close` was added to allow callers to receive and process the error result.\n\nUsers of all prior versions of `xmp_toolkit` are encouraged to update to version 1.9.0 to avoid undefined behavior.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"XMP Toolkit's `XmpFile::close` can trigger undefined behavior","id":"GHSA-66fw-43h8-f8p3","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["1.9.0"],"introduced":["0"],"last_affected":[],"package":"xmp_toolkit","purl":null,"source":"GHSA-66fw-43h8-f8p3"},{"ecosystem":"crates.io","fixed":["1.9.0"],"introduced":["0"],"last_affected":[],"package":"xmp_toolkit","purl":"pkg:cargo/xmp_toolkit","source":"GHSA-66fw-43h8-f8p3"},{"ecosystem":"crates.io","fixed":["1.9.0"],"introduced":["0.0.0-0"],"last_affected":[],"package":"xmp_toolkit","purl":"pkg:cargo/xmp_toolkit","source":"RUSTSEC-2024-0360"}],"products":null,"published":"2024-07-26","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can cause a process abort via undefined behavior in XmpFile::close, requiring an upgrade to the Rust xmp_toolkit library.","url":"https://insights.sbomify.com/GHSA-66fw-43h8-f8p3/"}