GHSA-66mv-xh68-h6v2 Denial of Service in @commercial/hapi
An attacker can crash the application by sending malformed CORS headers, causing a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-66mv-xh68-h6v2?
GHSA-66mv-xh68-h6v2 is a denial of service vulnerability in @commercial/hapi, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Affected versions of @commercial/hapi are vulnerable to Denial of Service. The CORS request handler has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.
Recommendation
Upgrade to versions 16.8.2, 17.9.2, 18.4.1, 19.1.1 or later.
Which versions are affected by GHSA-66mv-xh68-h6v2?
8 open source packages ship an affected version, including @commercial/hapi.
| Package | Affected | Fixed in |
|---|---|---|
@commercial/hapi npm | All versions | 16.8.2 |
@commercial/hapi npm | All versions | 16.8.2 |
@commercial/hapi npm | From 17.0.0 | 17.9.2 |
@commercial/hapi npm | From 17.0.0 | 17.9.2 |
@commercial/hapi npm | From 18.0.0 | 18.4.1 |
@commercial/hapi npm | From 18.0.0 | 18.4.1 |
2 more packages
@commercial/hapi npm | From 19.0.0 | 19.1.1 |
@commercial/hapi npm | From 19.0.0 | 19.1.1 |
How do I fix GHSA-66mv-xh68-h6v2?
Upgrade @commercial/hapi to a fixed version for your release line: 16.8.2, 17.9.2, 18.4.1 or 19.1.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is GHSA-66mv-xh68-h6v2 being exploited?
There is no known exploitation of GHSA-66mv-xh68-h6v2 in the wild and no public exploit code.