{"answers":{"affected":"8 open source packages ship an affected version, including @commercial/hapi.","exploited":"There is no known exploitation of GHSA-66mv-xh68-h6v2 in the wild and no public exploit code.","fix":"Upgrade @commercial/hapi to a fixed version for your release line: 16.8.2, 17.9.2, 18.4.1 or 19.1.1.","what":"GHSA-66mv-xh68-h6v2 is a denial of service vulnerability in @commercial/hapi, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-66mv-xh68-h6v2 and fix it if it is affected.\n\nWhat it is: GHSA-66mv-xh68-h6v2 is a denial of service vulnerability in @commercial/hapi, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-66mv-xh68-h6v2 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @commercial/hapi (npm): affected all versions; fixed in 16.8.2\n- @commercial/hapi (npm): affected all versions; fixed in 16.8.2\n- @commercial/hapi (npm): affected from 17.0.0; fixed in 17.9.2\n- @commercial/hapi (npm): affected from 17.0.0; fixed in 17.9.2\n- @commercial/hapi (npm): affected from 18.0.0; fixed in 18.4.1\n- @commercial/hapi (npm): affected from 18.0.0; fixed in 18.4.1\n- @commercial/hapi (npm): affected from 19.0.0; fixed in 19.1.1\n- @commercial/hapi (npm): affected from 19.0.0; fixed in 19.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-66mv-xh68-h6v2/ (Markdown: https://insights.sbomify.com/GHSA-66mv-xh68-h6v2/index.md)","id":"GHSA-66mv-xh68-h6v2","markdown":"https://insights.sbomify.com/GHSA-66mv-xh68-h6v2/index.md","name":"GHSA-66mv-xh68-h6v2","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js web framework","requires_auth":"none","summary":"An attacker can crash the application by sending malformed CORS headers, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Affected versions of `@commercial/hapi` are vulnerable to Denial of Service. The CORS request handler has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.\n\n## Recommendation\n\nUpgrade to versions 16.8.2, 17.9.2, 18.4.1, 19.1.1 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Denial of Service in @commercial/hapi","id":"GHSA-66mv-xh68-h6v2","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2020"},"n_packages":8,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["16.8.2"],"introduced":["0"],"last_affected":[],"package":"@commercial/hapi","purl":null,"source":"GHSA-66mv-xh68-h6v2"},{"ecosystem":"npm","fixed":["16.8.2"],"introduced":["0"],"last_affected":[],"package":"@commercial/hapi","purl":"pkg:npm/%40commercial/hapi","source":"GHSA-66mv-xh68-h6v2"},{"ecosystem":"npm","fixed":["17.9.2"],"introduced":["17.0.0"],"last_affected":[],"package":"@commercial/hapi","purl":null,"source":"GHSA-66mv-xh68-h6v2"},{"ecosystem":"npm","fixed":["17.9.2"],"introduced":["17.0.0"],"last_affected":[],"package":"@commercial/hapi","purl":"pkg:npm/%40commercial/hapi","source":"GHSA-66mv-xh68-h6v2"},{"ecosystem":"npm","fixed":["18.4.1"],"introduced":["18.0.0"],"last_affected":[],"package":"@commercial/hapi","purl":null,"source":"GHSA-66mv-xh68-h6v2"},{"ecosystem":"npm","fixed":["18.4.1"],"introduced":["18.0.0"],"last_affected":[],"package":"@commercial/hapi","purl":"pkg:npm/%40commercial/hapi","source":"GHSA-66mv-xh68-h6v2"},{"ecosystem":"npm","fixed":["19.1.1"],"introduced":["19.0.0"],"last_affected":[],"package":"@commercial/hapi","purl":null,"source":"GHSA-66mv-xh68-h6v2"},{"ecosystem":"npm","fixed":["19.1.1"],"introduced":["19.0.0"],"last_affected":[],"package":"@commercial/hapi","purl":"pkg:npm/%40commercial/hapi","source":"GHSA-66mv-xh68-h6v2"}],"products":null,"published":"2020-09-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can crash the application by sending malformed CORS headers, causing a denial of service.","url":"https://insights.sbomify.com/GHSA-66mv-xh68-h6v2/"}