{"answers":{"affected":"2 open source packages ship an affected version, including next.","exploited":"There is no known exploitation of GHSA-673q-mjm6-r5xr in the wild and no public exploit code.","fix":"Upgrade next to 16.4.1 or later.","what":"GHSA-673q-mjm6-r5xr is a vulnerability in next, published on 22 Oct 2026."},"fix_prompt":"Check this codebase for GHSA-673q-mjm6-r5xr and fix it if it is affected.\n\nWhat it is: GHSA-673q-mjm6-r5xr is a vulnerability in next, published on 22 Oct 2026. \nExploitation: There is no known exploitation of GHSA-673q-mjm6-r5xr in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- next (npm): affected from 16.0.0; fixed in 16.4.1\n- next (npm): affected from 16.0.0; fixed in 16.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-673q-mjm6-r5xr/ (Markdown: https://insights.sbomify.com/GHSA-673q-mjm6-r5xr/index.md)","id":"GHSA-673q-mjm6-r5xr","markdown":"https://insights.sbomify.com/GHSA-673q-mjm6-r5xr/index.md","name":"GHSA-673q-mjm6-r5xr","record":{"aliases":[],"analysis":null,"analysis_generated_by":null,"assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Impact\n\nA vulnerability in applications using App router with Cache Component can lead to remote code execution. The application needs to have a `use cache` function that returns multiple typed arrays.\n\n## Workaround\n\nThere is no known workaround for affected applications with such `use cache` functions. You should upgrade immediately even if your application does not have similar functions.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Next.js: Unauthenticated Remote Code Execution in `use cache` functions returning typed arrays","id":"GHSA-673q-mjm6-r5xr","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":null,"year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["16.4.1"],"introduced":["16.0.0"],"last_affected":[],"package":"next","purl":null,"source":"GHSA-673q-mjm6-r5xr"},{"ecosystem":"npm","fixed":["16.4.1"],"introduced":["16.0.0"],"last_affected":[],"package":"next","purl":"pkg:npm/next","source":"GHSA-673q-mjm6-r5xr"}],"products":null,"published":"2026-10-22","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":null,"url":"https://insights.sbomify.com/GHSA-673q-mjm6-r5xr/"}