{"answers":{"affected":"4 open source packages ship an affected version, including indico.","exploited":"There is no known exploitation of GHSA-67cx-rhhq-mfhq in the wild and no public exploit code.","fix":"Upgrade indico to a fixed version for your release line: 2.1.10 or 2.2.3.","what":"GHSA-67cx-rhhq-mfhq is a code injection vulnerability in indico, published on 11 Oct 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-67cx-rhhq-mfhq and fix it if it is affected.\n\nWhat it is: GHSA-67cx-rhhq-mfhq is a code injection vulnerability in indico, published on 11 Oct 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-67cx-rhhq-mfhq in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- indico (PyPI): affected all versions; fixed in 2.1.10\n- indico (PyPI): affected all versions; fixed in 2.1.10\n- indico (PyPI): affected from 2.2.0; fixed in 2.2.3\n- indico (PyPI): affected from 2.2.0; fixed in 2.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-67cx-rhhq-mfhq/ (Markdown: https://insights.sbomify.com/GHSA-67cx-rhhq-mfhq/index.md)","id":"GHSA-67cx-rhhq-mfhq","markdown":"https://insights.sbomify.com/GHSA-67cx-rhhq-mfhq/index.md","name":"GHSA-67cx-rhhq-mfhq","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Indico event management","requires_auth":"low_privilege","summary":"Malicious users can inject LaTeX commands to read local server files, requiring an upgrade to Indico.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Local file disclosure through LaTeX injection\n\n### Impact\nAn external audit of the Indico codebase has discovered a vulnerability in Indico's LaTeX sanitization code, which could have malicious users to run unsafe LaTeX commands on the server. Such commands allowed for example to read local files (e.g. `indico.conf`).\n\nAs far as we know it is not possible to write files or execute code using this vulnerability.\n\n### Patches\nYou need to update to [Indico 2.2.3](https://github.com/indico/indico/releases/tag/v2.2.3) as soon as possible.\nWe also released [Indico 2.1.10](https://github.com/indico/indico/releases/tag/v2.1.10) in case you cannot update to 2.2 for some reason.\nSee https://docs.getindico.io/en/stable/installation/upgrade/ for instructions on how to update.\n\n### Workarounds\nSetting `XELATEX_PATH = None` in `indico.conf` will result in an error when building a PDF, but without being able to run xelatex, the vulnerability cannot be abused.\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Open a thread in [our forum](https://talk.getindico.io/)\n* Email us privately at [indico-team@cern.ch](mailto:indico-team@cern.ch)","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"High severity vulnerability that affects indico","id":"GHSA-67cx-rhhq-mfhq","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2019"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["2.1.10"],"introduced":["0"],"last_affected":[],"package":"indico","purl":null,"source":"GHSA-67cx-rhhq-mfhq"},{"ecosystem":"PyPI","fixed":["2.1.10"],"introduced":["0"],"last_affected":[],"package":"indico","purl":"pkg:pypi/indico","source":"GHSA-67cx-rhhq-mfhq"},{"ecosystem":"PyPI","fixed":["2.2.3"],"introduced":["2.2.0"],"last_affected":[],"package":"indico","purl":null,"source":"GHSA-67cx-rhhq-mfhq"},{"ecosystem":"PyPI","fixed":["2.2.3"],"introduced":["2.2.0"],"last_affected":[],"package":"indico","purl":"pkg:pypi/indico","source":"GHSA-67cx-rhhq-mfhq"}],"products":null,"published":"2019-10-11","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Malicious users can inject LaTeX commands to read local server files, requiring an upgrade to Indico.","url":"https://insights.sbomify.com/GHSA-67cx-rhhq-mfhq/"}