GHSA-68c2-4mpx-qh95 Potential leakage of Sentry auth tokens by React Native SDK with Expo plugin
Developers using the Sentry React Native SDK with Expo may leak auth tokens if configured incorrectly, requiring token rotation and SDK upgrades.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-68c2-4mpx-qh95?
GHSA-68c2-4mpx-qh95 is a vulnerability in @sentry/react-native, published on 1 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Impact
SDK versions between and including 5.16.0 and 5.19.0 allowed Sentry auth tokens to be set in the optional authToken configuration parameter, for debugging purposes. Doing so would result in the auth token being built into the application bundle, and therefore the auth token could be potentially exposed in case the application bundle is subsequently published.
You may ignore this notification if you are not using authToken configuration parameter in your React Native SDK configuration or did not publish apps using this way of configuring the authToken.
If you had set the authToken in the plugin config previously, and built and published an app with that config, you should rotate your token.
Patches
The behavior that allowed setting an authToken parameter was fixed in SDK version 5.19.1 where, if this parameter was set, you will see a warning and the authToken would be removed before bundling the application.
Workarounds
- Remove
authTokenfrom the plugin configuration. - If you had set the
authTokenin the plugin config previously, and built and published an app with that config, you should rotate your token.
References
Which versions are affected by GHSA-68c2-4mpx-qh95?
2 open source packages ship an affected version, including @sentry/react-native.
| Package | Affected | Fixed in |
|---|---|---|
@sentry/react-native npm | From 5.16.0 | 5.19.1 |
@sentry/react-native npm | From 5.16.0 | 5.19.1 |
How do I fix GHSA-68c2-4mpx-qh95?
Upgrade @sentry/react-native to 5.19.1 or later.
Is GHSA-68c2-4mpx-qh95 being exploited?
There is no known exploitation of GHSA-68c2-4mpx-qh95 in the wild and no public exploit code.