{"answers":{"affected":"2 open source packages ship an affected version, including @sentry/react-native.","exploited":"There is no known exploitation of GHSA-68c2-4mpx-qh95 in the wild and no public exploit code.","fix":"Upgrade @sentry/react-native to 5.19.1 or later.","what":"GHSA-68c2-4mpx-qh95 is a vulnerability in @sentry/react-native, published on 1 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-68c2-4mpx-qh95 and fix it if it is affected.\n\nWhat it is: GHSA-68c2-4mpx-qh95 is a vulnerability in @sentry/react-native, published on 1 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-68c2-4mpx-qh95 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @sentry/react-native (npm): affected from 5.16.0; fixed in 5.19.1\n- @sentry/react-native (npm): affected from 5.16.0; fixed in 5.19.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-68c2-4mpx-qh95/ (Markdown: https://insights.sbomify.com/GHSA-68c2-4mpx-qh95/index.md)","id":"GHSA-68c2-4mpx-qh95","markdown":"https://insights.sbomify.com/GHSA-68c2-4mpx-qh95/index.md","name":"GHSA-68c2-4mpx-qh95","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"React Native SDK","requires_auth":"none","summary":"Developers using the Sentry React Native SDK with Expo may leak auth tokens if configured incorrectly, requiring token rotation and SDK upgrades.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nSDK versions between and including 5.16.0 and 5.19.0 allowed Sentry auth tokens to be set in the optional authToken configuration parameter, for debugging purposes. Doing so would result in the auth token being built into the application bundle, and therefore the auth token could be potentially exposed in case the application bundle is subsequently published.\n\nYou may ignore this notification if you are not using `authToken` configuration parameter in your React Native SDK configuration or did not publish apps using this way of configuring the `authToken`.\n\nIf you had set the `authToken` in the plugin config previously, and built and published an app with that config, you should [rotate your token](https://docs.sentry.io/product/accounts/auth-tokens/).\n\n### Patches\nThe behavior that allowed setting an `authToken` parameter was fixed in SDK version 5.19.1 where, if this parameter was set, you will see a warning and the `authToken` would be removed before bundling the application.\n\n### Workarounds\n1. Remove `authToken` from the plugin configuration.\n2. If you had set the `authToken` in the plugin config previously, and built and published an app with that config, you should [rotate your token](https://docs.sentry.io/product/accounts/auth-tokens/).\n\n### References\n* [sentry-react-native 5.19.1 release notes](https://github.com/getsentry/sentry-react-native/releases/tag/5.19.1)\n* https://github.com/getsentry/sentry-docs/pull/9244","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Potential leakage of Sentry auth tokens by React Native SDK with Expo plugin","id":"GHSA-68c2-4mpx-qh95","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["5.19.1"],"introduced":["5.16.0"],"last_affected":[],"package":"@sentry/react-native","purl":null,"source":"GHSA-68c2-4mpx-qh95"},{"ecosystem":"npm","fixed":["5.19.1"],"introduced":["5.16.0"],"last_affected":[],"package":"@sentry/react-native","purl":"pkg:npm/%40sentry/react-native","source":"GHSA-68c2-4mpx-qh95"}],"products":null,"published":"2024-03-01","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Developers using the Sentry React Native SDK with Expo may leak auth tokens if configured incorrectly, requiring token rotation and SDK upgrades.","url":"https://insights.sbomify.com/GHSA-68c2-4mpx-qh95/"}