{"answers":{"affected":"2 open source packages ship an affected version, including litellm.","exploited":"There is no known exploitation of GHSA-69x8-hrgq-fjj8 in the wild and no public exploit code.","fix":"Upgrade litellm to 1.83.0 or later.","what":"GHSA-69x8-hrgq-fjj8 is an authentication bypass vulnerability in litellm, published on 8 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-69x8-hrgq-fjj8 and fix it if it is affected.\n\nWhat it is: GHSA-69x8-hrgq-fjj8 is an authentication bypass vulnerability in litellm, published on 8 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-69x8-hrgq-fjj8 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- litellm (PyPI): affected all versions; fixed in 1.83.0\n- litellm (PyPI): affected all versions; fixed in 1.83.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-69x8-hrgq-fjj8/ (Markdown: https://insights.sbomify.com/GHSA-69x8-hrgq-fjj8/index.md)","id":"GHSA-69x8-hrgq-fjj8","markdown":"https://insights.sbomify.com/GHSA-69x8-hrgq-fjj8/index.md","name":"GHSA-69x8-hrgq-fjj8","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"LiteLLM Python library","requires_auth":"low_privilege","summary":"Authenticated users can steal password hashes and bypass authentication to escalate privileges and take over accounts.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nThree issues combine into a full authentication bypass chain:\n\n1. Weak hashing: User passwords are stored as unsalted SHA-256 hashes, making them vulnerable to rainbow table attacks and trivially identifying users with identical passwords.\n2. Hash exposure: Multiple API endpoints (/user/info, /user/update, /spend/users) return the password hash field in responses to any authenticated user regardless of role. Plaintext passwords could also potentially be exposed in certain scenarios.\n4. Pass-the-hash: The /v2/login endpoint accepts the raw SHA-256 hash as a valid password without re-hashing, allowing direct login with a stolen\n\nAn already authenticated user can retrieve another user's password hash from the API and use it to log in as that user. This enables full privilege escalation in three HTTP requests.\n\n### Patches\n\nFixed in v1.83.0. Passwords are now hashed with scrypt (random 16-byte salt, n=16384, r=8, p=1). Password hashes are stripped from all API responses. Existing SHA-256 hashes are transparently migrated on next login.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"LiteLLM: Password hash exposure and pass-the-hash authentication bypass","id":"GHSA-69x8-hrgq-fjj8","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["1.83.0"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":null,"source":"GHSA-69x8-hrgq-fjj8"},{"ecosystem":"PyPI","fixed":["1.83.0"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":"pkg:pypi/litellm","source":"GHSA-69x8-hrgq-fjj8"}],"products":null,"published":"2026-04-08","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Authenticated users can steal password hashes and bypass authentication to escalate privileges and take over accounts.","url":"https://insights.sbomify.com/GHSA-69x8-hrgq-fjj8/"}