# GHSA-6c73-2v8x-qpvm: Argo Server TLS requests could be forged by attacker with network access

> Attackers with network access can extract hardcoded TLS keys from Argo Server images to decrypt traffic or forge requests.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Aug 2021
- **Also known as:** GO-2022-0388

## What is GHSA-6c73-2v8x-qpvm?

GHSA-6c73-2v8x-qpvm is a vulnerability in github.com/argoproj/argo-workflows, published on 23 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Impact

We are not aware of any exploits. This is a pro-active fix.

Impacted: 

* You are running Argo Server < v3.0 with `--secure=true` or >= v3.0 with `--secure` unspecified (note - running in secure mode is recommended regardless).
* The attacker is within your network. If you expose Argo Server to the Internet then "your network" is "the Internet". 

The Argo Server's keys are packaged within the image. They could be extracted and used to decrypt traffic, or forge requests.

### Patches

https://github.com/argoproj/argo-workflows/pull/6540

### Workarounds

* Make sure that your Argo Server service or pod are not directly accessible outside of your cluster. Put TLS load balancer in front of it.

This was identified by engineers at Jetstack.io

## Which versions are affected by GHSA-6c73-2v8x-qpvm?

7 open source packages ship an affected version, including github.com/argoproj/argo-workflows/v3, github.com/argoproj/argo-workflows and github.com/argoproj/argo-workflows/v2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/argoproj/argo-workflows/v3` | Go | From 3.0.0 | 3.0.9, 3.1.6 |
| `github.com/argoproj/argo-workflows/v3` | Go | From 3.0.0 | 3.0.9 |
| `github.com/argoproj/argo-workflows/v3` | Go | From 3.0.0 | 3.0.9 |
| `github.com/argoproj/argo-workflows/v3` | Go | From 3.1.0 | 3.1.6 |
| `github.com/argoproj/argo-workflows/v3` | Go | From 3.1.0 | 3.1.6 |
| `github.com/argoproj/argo-workflows` | Go | All versions | None |
| `github.com/argoproj/argo-workflows/v2` | Go | All versions | None |

## How do I fix GHSA-6c73-2v8x-qpvm?

Upgrade github.com/argoproj/argo-workflows/v3 to a fixed version for your release line: 3.0.9 or 3.1.6.

## Is GHSA-6c73-2v8x-qpvm being exploited?

There is no known exploitation of GHSA-6c73-2v8x-qpvm in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-6c73-2v8x-qpvm and fix it if it is affected.

What it is: GHSA-6c73-2v8x-qpvm is a vulnerability in github.com/argoproj/argo-workflows, published on 23 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-6c73-2v8x-qpvm in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/argoproj/argo-workflows/v3 (Go): affected from 3.0.0; fixed in 3.0.9, 3.1.6
- github.com/argoproj/argo-workflows/v3 (Go): affected from 3.0.0; fixed in 3.0.9
- github.com/argoproj/argo-workflows/v3 (Go): affected from 3.0.0; fixed in 3.0.9
- github.com/argoproj/argo-workflows/v3 (Go): affected from 3.1.0; fixed in 3.1.6
- github.com/argoproj/argo-workflows/v3 (Go): affected from 3.1.0; fixed in 3.1.6
- github.com/argoproj/argo-workflows (Go): affected all versions; no fix listed
- github.com/argoproj/argo-workflows/v2 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-6c73-2v8x-qpvm/ (Markdown: https://insights.sbomify.com/GHSA-6c73-2v8x-qpvm/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-6c73-2v8x-qpvm

---
From sbomify Insights: https://insights.sbomify.com/GHSA-6c73-2v8x-qpvm/
Summaries are generated and may contain mistakes; the official description above is the record.
