{"answers":{"affected":"3 open source packages ship an affected version, including lopdf.","exploited":"There is no known exploitation of GHSA-6fj4-rcr3-r7rr in the wild and no public exploit code.","fix":"Upgrade lopdf to 0.42.0 or later.","what":"GHSA-6fj4-rcr3-r7rr is a denial of service vulnerability in lopdf, published on 21 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-6fj4-rcr3-r7rr and fix it if it is affected.\n\nWhat it is: GHSA-6fj4-rcr3-r7rr is a denial of service vulnerability in lopdf, published on 21 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-6fj4-rcr3-r7rr in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- lopdf (crates.io): affected all versions; fixed in 0.42.0\n- lopdf (crates.io): affected all versions; fixed in 0.42.0\n- lopdf (crates.io): affected from 0.0.0-0; fixed in 0.42.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-6fj4-rcr3-r7rr/ (Markdown: https://insights.sbomify.com/GHSA-6fj4-rcr3-r7rr/index.md)","id":"GHSA-6fj4-rcr3-r7rr","markdown":"https://insights.sbomify.com/GHSA-6fj4-rcr3-r7rr/index.md","name":"GHSA-6fj4-rcr3-r7rr","record":{"aliases":["RUSTSEC-2026-0187"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust PDF library","requires_auth":"none","summary":"Attackers can crash applications parsing untrusted PDFs using lopdf by sending a small file with deeply nested objects, causing a stack overflow.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"`lopdf::Document::load_mem` (and the other `load*` entry points) parses nested PDF arrays and dictionaries with unbounded recursion. A small crafted PDF whose Catalog contains a deeply nested array (`/X [[[ … ]]]`, on the order of 10,000 levels) exhausts the call stack and aborts the process with `SIGABRT`.\n\nBecause this is a stack-overflow abort rather than a `panic!`, it cannot be caught with `catch_unwind`: any service that parses untrusted PDF input with lopdf can be crashed by a ~21 KB file, resulting in a denial of service.\n\nConfirmed on lopdf 0.41.0 and earlier; fixed in 0.42.0. Default configuration, no features changed.\n\n## Proof of concept\n\n```rust\nfn main() {\n    let bytes = std::fs::read(\"poc.pdf\").unwrap(); // ~10,380-deep nested array in the Catalog\n    let _ = lopdf::Document::load_mem(\u0026bytes);     // stack overflow -\u003e SIGABRT\n}\n```\n\nAn equivalent PoC is a minimal PDF whose Catalog `/X` value is `\"[\" * 10380 + \"]\" * 10380`.\n\n## Suggested fix\n\nEnforce a maximum object-nesting depth in the parser and return an `Err` instead of recursing without bound.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"lopdf has a stack overflow via deeply nested PDF objects","id":"GHSA-6fj4-rcr3-r7rr","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["0.42.0"],"introduced":["0"],"last_affected":[],"package":"lopdf","purl":null,"source":"GHSA-6fj4-rcr3-r7rr"},{"ecosystem":"crates.io","fixed":["0.42.0"],"introduced":["0"],"last_affected":[],"package":"lopdf","purl":"pkg:cargo/lopdf","source":"GHSA-6fj4-rcr3-r7rr"},{"ecosystem":"crates.io","fixed":["0.42.0"],"introduced":["0.0.0-0"],"last_affected":[],"package":"lopdf","purl":"pkg:cargo/lopdf","source":"RUSTSEC-2026-0187"}],"products":null,"published":"2026-06-21","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can crash applications parsing untrusted PDFs using lopdf by sending a small file with deeply nested objects, causing a stack overflow.","url":"https://insights.sbomify.com/GHSA-6fj4-rcr3-r7rr/"}